[Solved] 0.3.4 Unable to start on Raspbian

qDslrDashbord error reports
SdP
Posts: 15
Joined: 27 Jan 2016, 08:43

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by SdP » 27 Jan 2016, 19:48

libQt5EglDeviceIntegration.so.5 and libQt5DBus.so.5 found
sudo ln libQt5EglDeviceIntegration.so.5.5.1 /usr/lib/arm-linux-gnueabihf/libQt5EglDeviceIntegration.so.5
sudo ln libQt5DBus.so.5.5.1 /usr/lib/arm-linux-gnueabihf/libQt5DBus.so.5
I still need
libts-0.0.so.0 => not found
libinput.so.5 => not found

Bertsz
Posts: 9
Joined: 16 Jan 2016, 20:03

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by Bertsz » 27 Jan 2016, 20:50

The thing is, I installed a lot of other suff through apt-get. And it seems like the two are not part of the bundled libraries. I just ran a quick

Code: Select all

apt-cache search libinput
and it looks like you will have to install this package:

Code: Select all

apt-get install libinput5
As for libts-0.0.so.0, I have no idea where this is part of, but you could try to install these:

Code: Select all

apt-get install libtsan0 libtsm3 libtsk10 libtspi1
If that doesn't work you could also install qt5-default, if you haven't already

SdP
Posts: 15
Joined: 27 Jan 2016, 08:43

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by SdP » 27 Jan 2016, 21:07

pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ sudo apt-get install libinput5
Reading package lists... Done
Building dependency tree
Reading state information... Done
libinput5 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ sudo apt-get install libtsan0 libtsm3 libtsk10 libtspi1
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libtsan0
So I run
sudo apt-get install libtsm3 libtsk10 libtspi1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
libafflib0 libbfio1 libewf2
The following NEW packages will be installed:
libafflib0 libbfio1 libewf2 libtsk10 libtsm3 libtspi1
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
and now
apt-cache search libinput
libinput-dev - input device management and event handling library - development files
libinput-pad-dev - On-screen Input Pad to Send Characters with Mouse - dev
libinput-pad-xtest - On-screen Input Pad to Send Characters with Mouse - xtest
libinput-pad1 - On-screen Input Pad to Send Characters with Mouse - libs
libinput5 - input device management and event handling library - shared library
libinput5-dbg - input device management and event handling library - debugging symbols
BUT :oops:

NOPE
pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ sudo ./qDslrDashboard.sh
pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ This application failed to start because it could not find or load the Qt platform plugin "eglfs".

Available platform plugins are: eglfs (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), linuxfb (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), minimal (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), minimalegl (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), offscreen (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), linuxfb, minimal, minimalegl, offscreen.

Reinstalling the application may fix this problem.
ldd Qt_Libraries/plugins/platforms/libqeglfs.so
linux-vdso.so.1 (0x7ed1c000)
/usr/lib/arm-linux-gnueabihf/libarmmem.so (0x76f57000)
libQt5EglDeviceIntegration.so.5 => /usr/lib/arm-linux-gnueabihf/libQt5EglDeviceIntegration.so.5 (0x76ef9000)
libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0x76ee6000)
libts-0.0.so.0 => not found
libfontconfig.so.1 => /usr/lib/arm-linux-gnueabihf/libfontconfig.so.1 (0x76eb4000)
libfreetype.so.6 => /usr/lib/arm-linux-gnueabihf/libfreetype.so.6 (0x76e1c000)
libQt5DBus.so.5 => /usr/lib/arm-linux-gnueabihf/libQt5DBus.so.5 (0x76dad000)
libgthread-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libgthread-2.0.so.0 (0x76d9b000)
libglib-2.0.so.0 => /lib/arm-linux-gnueabihf/libglib-2.0.so.0 (0x76c98000)
libinput.so.5 => /usr/lib/arm-linux-gnueabihf/libinput.so.5 (0x76c7a000)
libudev.so.1 => /lib/arm-linux-gnueabihf/libudev.so.1 (0x76c5d000)
libEGL.so => /opt/vc/lib/libEGL.so (0x76c33000)
libQt5Gui.so.5 => /usr/lib/arm-linux-gnueabihf/libQt5Gui.so.5 (0x767ed000)
libQt5Core.so.5 => /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5 (0x762f7000)
libGLESv2.so => /opt/vc/lib/libGLESv2.so (0x762da000)
libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0x762b2000)
libstdc++.so.6 => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 (0x761d5000)
libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0x7615a000)
libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0x7612d000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0x75fec000)
/lib/ld-linux-armhf.so.3 (0x54b5c000)
libts-0.0.so.0 => not found
libexpat.so.1 => /lib/arm-linux-gnueabihf/libexpat.so.1 (0x75fb9000)
libz.so.1 => /lib/arm-linux-gnueabihf/libz.so.1 (0x75f92000)
libpng12.so.0 => /lib/arm-linux-gnueabihf/libpng12.so.0 (0x75f62000)
libpcre.so.3 => /lib/arm-linux-gnueabihf/libpcre.so.3 (0x75eef000)
libmtdev.so.1 => /usr/lib/arm-linux-gnueabihf/libmtdev.so.1 (0x75ee2000)
libevdev.so.2 => /usr/lib/arm-linux-gnueabihf/libevdev.so.2 (0x75ec1000)
librt.so.1 => /lib/arm-linux-gnueabihf/librt.so.1 (0x75eaa000)
libbcm_host.so => /opt/vc/lib/libbcm_host.so (0x75e8c000)
libvchiq_arm.so => /opt/vc/lib/libvchiq_arm.so (0x75e7e000)
libvcos.so => /opt/vc/lib/libvcos.so (0x75e6c000)
And this is better as there before as it is only libts-0.0.so.0 => not found

SdP
Posts: 15
Joined: 27 Jan 2016, 08:43

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by SdP » 27 Jan 2016, 21:12

Going with sudo apt-get install qt5-default
pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ sudo apt-get install qt5-default
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
libdrm-dev libdrm-exynos1 libdrm-omap1 libegl1-mesa-dev libegl1-mesa-drivers
libgles2-mesa libgles2-mesa-dev libopenvg1-mesa libpthread-stubs0-dev
libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5
libqt5opengl5 libqt5opengl5-dev libqt5printsupport5 libqt5sql5
libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libwayland-dev
libwayland-egl1-mesa libx11-dev libx11-doc libx11-xcb-dev libxau-dev
libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev libxcb-icccm4
libxcb-image0 libxcb-keysyms1 libxcb-present-dev libxcb-randr0
libxcb-randr0-dev libxcb-render-util0 libxcb-render0-dev libxcb-shape0-dev
libxcb-sync-dev libxcb-xfixes0-dev libxcb-xkb1 libxcb1-dev libxdamage-dev
libxdmcp-dev libxext-dev libxfixes-dev libxkbcommon-x11-0 libxshmfence-dev
libxxf86vm-dev qt5-qmake qtbase5-dev qtbase5-dev-tools qttranslations5-l10n
x11proto-core-dev x11proto-damage-dev x11proto-dri2-dev x11proto-fixes-dev
x11proto-gl-dev x11proto-input-dev x11proto-kb-dev x11proto-xext-dev
x11proto-xf86vidmode-dev xorg-sgml-doctools xtrans-dev
x11proto-xf86vidmode-dev xorg-sgml-doctools xtrans-dev
Suggested packages:
libxcb-doc libxext-doc firebird-dev libgl1-mesa-dev libmysqlclient-dev
libpq-dev libsqlite3-dev unixodbc-dev
The following NEW packages will be installed:
libdrm-dev libdrm-exynos1 libdrm-omap1 libegl1-mesa-dev libegl1-mesa-drivers
libgles2-mesa libgles2-mesa-dev libopenvg1-mesa libpthread-stubs0-dev
libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5
libqt5opengl5 libqt5opengl5-dev libqt5printsupport5 libqt5sql5
libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libwayland-dev
libwayland-egl1-mesa libx11-dev libx11-doc libx11-xcb-dev libxau-dev
libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev libxcb-icccm4
libxcb-image0 libxcb-keysyms1 libxcb-present-dev libxcb-randr0
libxcb-randr0-dev libxcb-render-util0 libxcb-render0-dev libxcb-shape0-dev
libxcb-sync-dev libxcb-xfixes0-dev libxcb-xkb1 libxcb1-dev libxdamage-dev
libxdmcp-dev libxext-dev libxfixes-dev libxkbcommon-x11-0 libxshmfence-dev
libxxf86vm-dev qt5-default qt5-qmake qtbase5-dev qtbase5-dev-tools
qttranslations5-l10n x11proto-core-dev x11proto-damage-dev x11proto-dri2-dev
x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev x11proto-kb-dev
x11proto-xext-dev x11proto-xf86vidmode-dev xorg-sgml-doctools xtrans-dev
0 upgraded, 67 newly installed, 0 to remove and 0 not upgraded.
Need to get 18.7 MB of archives.
After this operation, 81.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
BUT at the end
libts-0.0.so.0 => not found

AND
pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ sudo ./qDslrDashboard.sh
pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ This application failed to start because it could not find or load the Qt platform plugin "eglfs".

Available platform plugins are: eglfs (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), linuxfb (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), minimal (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), minimalegl (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), offscreen (from /home/pi/qDslrDashboard_V0.3.4_RPI2/./Qt_Libraries/plugins/platforms), linuxfb, minimal, minimalegl, offscreen.

Reinstalling the application may fix this problem.

Bertsz
Posts: 9
Joined: 16 Jan 2016, 20:03

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by Bertsz » 27 Jan 2016, 21:31

Apparantly there are some more packages on arm than there are on amd64. Since that's where I ran the package search, because I was too lazy to boot up my pi. But now I did, and there appears to be a libts-bin package, which I already installed because I'm using a touch-screen (and this is a touchscreen library). Sorry for the inconvenience, but I think this should do the trick now :D
So just run

Code: Select all

apt-get install libts-bin libts-0.0-0

SdP
Posts: 15
Joined: 27 Jan 2016, 08:43

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by SdP » 27 Jan 2016, 21:41

pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ sudo apt-get install libts-bin libts-0.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
tsconf
The following NEW packages will be installed:
libts-0.0-0 libts-bin tsconf
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 67.7 kB of archives.
After this operation, 238 kB of additional disk space will be used.
Do you want to continue? [Y/n]

YES YES YES

Still some problem but I get the DSLR Dashboard main window!!!

FYI:
pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ sudo ./qDslrDashboard.sh
pi@raspberrypi:~/qDslrDashboard_V0.3.4_RPI2 $ Unable to query physical screen size, defaulting to 100 dpi.
To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (in millimeters).
PulseAudioService: pa_context_connect() failed
qml: windowRoot completed
qml: manager focus
qml: managerOverlayLoader active focus changed true
qml: manager overlay got focus true
qml: button active focus changed true index 0
qml: displayScreen DeviceScreen.qml
qml: on device buttons changed null
qml: getTime 0
qml: screenModel DeviceScreen(0x1a13cd0) devBtn null
qml: get osd source qml
qml: DeviceScreen completed
qml: ScreenBase completed DeviceScreen(0x1a13cd0)
qml: error:
glGetError 0x500
qml: button key pressed 16777216
qml: manager overlay key 16777216
qml: Timer triggered
qml: managerOverlayLoader active focus changed false
qml: manager overlay got focus false
qml: button active focus changed false index 0
qml: messagUi activeFocus true
qml: managerOverlayLoader active focus changed true
qml: manager overlay got focus true
qml: button active focus changed true index 0
qml: messagUi activeFocus false
qml: managerOverlayLoader active focus changed false
qml: manager overlay got focus false
qml: button active focus changed false index 0
qml: windows destroyed
qml: DeviceScreen destroyed
qml: ScreenBase destroyed
PulseAudioService: pa_context_connect() failed
if I don't use sudo I get this
./qDslrDashboard.sh
./qDslrDashboard.sh: line 26: /dev/nul: Permission denied


But then the application runs all the same :D
so sudo is non necessary to run qDslrDashboard.sh


Thank you again!
SdP

SdP
Posts: 15
Joined: 27 Jan 2016, 08:43

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by SdP » 27 Jan 2016, 21:56

And works fine with Sony A7R MK1 :D

Tomorrow Canon 5DMK3 USB and WIFI with TPLink MR3040 ....

Bertsz
Posts: 9
Joined: 16 Jan 2016, 20:03

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by Bertsz » 28 Jan 2016, 21:06

That's some fancy gear :D
Anyways, it's nice I could help you, and maybe if I find the time, I'll write a nice step by steo guide to make this thing work, without knowing too much about linux.

SdP
Posts: 15
Joined: 27 Jan 2016, 08:43

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by SdP » 29 Jan 2016, 08:36

Here is my report with Canon 5DMK3 USB and WIFI with TPLink MR3040!
I used with both the Raspberry PI 2 and a Win10 Notebook.

qDslrDashbord works like a charm and is perfectly symmetrical with both system.
I flashed my TPLink MR3040 in 2 minutes and in the next 3 I was connected to my Canon 5DMK3 shooting remotely!
The Live view lag is there but minimal so I give a full 9.0 out of 10 to this program! (FYI I'm a professional photographer!).
Anyways, it's nice I could help you, and maybe if I find the time, I'll write a nice step by steo guide to make this thing work, without knowing too much about linux.
About linux I'm not too an expert so if you write a guide about how to install qDslrDashbord on RPI2 it will help a lot of guys with our same problem (i suppose it is ALL people running on RPI, as I started with a clean SD freshly downloaded from https://www.raspberrypi.org/downloads/)

I posted on the forum *ALL* the commands I used, so maybe it can help you in writing a script creating all the symbolic links and the install of all the libraries!
Remember: my was a clean install then all I did was sudo apt-get update and sudo apt-get upgrade (90 packets an 40 minutes...)

bobyg26
Posts: 7
Joined: 20 Mar 2016, 04:37

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by bobyg26 » 20 Mar 2016, 04:43

I have tried to follow this as best as I could, but not quite coming out with a result.

I'm getting the qDslrDashboard window to launch, however will not recognise cameras. I can see from some of the packages I have tried to install that all the opencv and Qt5 are saying they are not a symbolic link, which I think means because there is 2 of the same?

I have also changed the standard pi username and password, I did that before trying to install everything, but maybe its a permissions thing.

Any help would be appreciated

Al

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 5 guests