[Solved] 0.3.4 Unable to start on Raspbian

qDslrDashbord error reports
bobyg26
Posts: 7
Joined: 20 Mar 2016, 04:37

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by bobyg26 » 20 Mar 2016, 04:48

Bertsz wrote:That's some fancy gear :D
Anyways, it's nice I could help you, and maybe if I find the time, I'll write a nice step by steo guide to make this thing work, without knowing too much about linux.
Did you end up making a step by step guide. I have found most of my way through with the help of some of the stuff on this thread. And I have qDslrDashboard loading up, however I think there may be some permissions errors as some of the opencv and Qt5 files are coming up 'not a symbolic link'

SdP
Posts: 15
Joined: 27 Jan 2016, 08:43

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by SdP » 20 Mar 2016, 18:24

It is not really a quick guide, but if you follow my step, it is supposed to work...

I tested on Jessie 8.1, Raspberry PI 2, Canon 5D MK3 (connected to USB and TP-Link MR3040 ddserver OpenWrt firmware) and Sony A7R MK1
I fresh installed from https://www.raspberrypi.org/downloads/raspbian/
Then did the standard qdslrdashboard (0.3.4) install + fix then:

http://dslrdashboard.info/phpBB3/viewto ... 1480#p4083

and did install all the updates and firmware updates:

Code: Select all

sudo apt-get update
sudo apt-get upgrade
sudo reboot

sudo apt-get install rpi-update
sudo rpi-update
sudo reboot

sudo apt-get update
sudo apt-get upgrade
sudo reboot

bobyg26
Posts: 7
Joined: 20 Mar 2016, 04:37

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by bobyg26 » 22 Mar 2016, 03:17

Ill give that a go. Are you still receiving permissions errors when loading the .sh file?

I saw the fix. Is that just a case of replacing the original file?

valid_like_salad
Posts: 8
Joined: 21 Jan 2016, 06:54

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by valid_like_salad » 02 Jun 2016, 07:51

was anyone successful in writing a script to automate this? I'm hoping to achieve an install on a raspberry pi 3 using these instructions, but a precompiled disk image or at least a script would make life a million times easier right now. I will happily contribute my SD card image to the forum if I am successful.

Danansmith
Posts: 1
Joined: 15 Jun 2016, 04:16

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by Danansmith » 27 Jun 2016, 03:31

Great work! Thanks for all your hard work. Excellent post! Thanks again for posting this here.
popular bubble football:Bubble soccer

PiKmera
Posts: 8
Joined: 27 Aug 2017, 19:14

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by PiKmera » 27 Aug 2017, 19:33

Hi all!

I'm trying to install the server in a Rpi B2, even following the instructions here or in the Github, there's not any way it runs there. I'm sure I'm making something wrong.

1st method:
1. Flash latest Raspbian ISO from Rpi websited into a SD card
2. Run sudo apt-get update && apt-get upgrade
3. Reboot
4. Download and unzip the file (In /home/pi/Downloads/) downloaded from https://dslrdashboard.info/download/ras ... pi-v3-5-3/
5. Run sudo apt-get update && apt-get upgrade
6. Reboot
7. Enter to the folder /home/pi/Downloads/qDslrDashboard_V3.5.3_RPI/ and run sudo ./qDslrDashboard.sh
8. There's always a missing libraries.. Even I finally install the missing library, after run the command again, there's another missing library then and so on.

2nd method:
1. Flash latest Raspbian ISO from Rpi websited into a SD card
2. Run sudo apt-get update && apt-get upgrade
3. Reboot
4. Run git clone git://github.com/hubaiz/DslrDashboardServer package/DslrDashboardServer
5. Run sudo apt-get update && apt-get upgrade
6. Reboot
7. Run sudo make menuconfig
8. Error message "no rule to make target 'menuconfig'"

- -
I'm not sure if the problem might be in the memory assigned to the GPU, when I set it to 512, the Pi won't boot. Once I set it for any lower value, it boots normally. Even gpu_mem_1024=512 let me boot the Pi, however when check the memory it says 64M.

Any suggestion where I'm making the mistake in the procedure?

Thanks in advance!

hubaiz
Site Admin
Posts: 1703
Joined: 27 Jan 2015, 18:58

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by hubaiz » 28 Aug 2017, 11:38

qDslrDashboard and DslrDashboardServer are not the same.
To compile DslrDashboardServer on Raspbian please follow the instructions here: https://github.com/hubaiz/DslrDashboard ... d-raspbian

Regarding the missing libraries for qDslrDashboard maybe if you post them or the error message maybe we can help.

Jarrod
Posts: 15
Joined: 27 Aug 2017, 14:40

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by Jarrod » 31 Aug 2017, 19:47

1. Flash latest Raspbian ISO from Rpi websited into a SD card
.
.
.
8. There's always a missing libraries.. Even I finally install the missing library, after run the command again, there's another missing library then and so on.
I know exactly what this issue is - I ran into it yesterday.

As of Aug 17, the d/l page at raspberrypi.org gives you Stretch, not Jessie. Stretch has all new libraries. This breaks dependencies inside the Qt, etc. libraries that you include with your RPi qDD binary distribution. I tried for around an hour to make soft links of the old library names that point to the new library files, but there are literally dozens. I finally gave up and decided that I would go back to Jessie if I want to run the full qDD on my RPi 3.

What is needed is a new build of qDD against the new libraries in Rasbian Stretch, or static versions of the libraries you currently redistribute in the RPi distribution of qDD, or to instruct users how to find the older Jessie images to install on their RPi. Those are not too easy to find or recognize for the casual/new user browsing the usual sites where such users are directed to get OS images.

canonman
Posts: 3
Joined: 23 Sep 2018, 21:39

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by canonman » 24 Sep 2018, 07:35

Hello all.. Just curious if there is any updates coming soon?

I was able to get qdslr "KINDA" working with Raspbian Jessie upgrade.
I got the screen to load, but icons for the gui interface would not load.

I tried a reboot and the rpi fell back to not finding the platform for eglfs..

I'm going to sleep now..

hubaiz
Site Admin
Posts: 1703
Joined: 27 Jan 2015, 18:58

Re: [Solved] 0.3.4 Unable to start on Raspbian

Post by hubaiz » 25 Sep 2018, 18:33

Not sure what you mean with update?
The latest qDslrDashboard V3.5.6 can be downloaded for Raspbian Stretch and it is working fine ( https://dslrdashboard.info/downloads/ )

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests