Language issue:Windows Ver. - Font problems

qDslrDashbord error reports
Post Reply
benjenq
Posts: 2
Joined: 03 Apr 2016, 11:31

Language issue:Windows Ver. - Font problems

Post by benjenq »

Hi All:

I'm a user from Taiwan and my windows language version is Traditional-Chinese. I always got the language issue when launch qDslrDashboard application. Attach screenshot file for more detail.

It appear in all windows (Windows XP / 7 / 8 /10) with Traditional-Chinese Version. Does this issue could be fixed ?
Attachments
2016-04-03.png
2016-04-03.png (44.29 KiB) Viewed 10652 times

luckylz2dd
Posts: 6
Joined: 27 Nov 2018, 08:54

Re: Language issue:Windows Ver.

Post by luckylz2dd »

I recently faced the same issue in Simplified-Chinese version of Windows too. And searched the whole forum, it's not the reason of OpenCV.
And I found out it's cause by Non-English version Windows font problem. So I have this issue fixed with replacing one of the font name "SimSun & NSimSun (TrueType)" to "Microsoft YaHei & Microsoft YaHei UI (TrueType)".

And I guess in Traditional-Chinese version, it's similiar.
Defaut Font
Defaut Font
err2.jpg (251.88 KiB) Viewed 7541 times
Replace to YaHei
Replace to YaHei
good2.jpg (244.93 KiB) Viewed 7541 times
Just change the font file name by regedit and sign off will take effect.

The following code, can be used to replace & restore the font file.
Replace Reg:

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
"SimSun & NSimSun (TrueType)"="msyh.ttc"
Restore Reg:

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
"SimSun & NSimSun (TrueType)"="simsun.ttc"

Post Reply