Error with qDslrDashboard V3.6.4 for Raspberry Pi 4

qDslrDashbord error reports
lispm
Posts: 10
Joined: 17 Apr 2021, 14:03

Re: Error with qDslrDashboard V3.6.4 for Raspberry Pi 4

Post by lispm »

zidqat wrote:
10 Aug 2021, 02:18
...
i install the library:

sudo apt-get install libxcb-xinput0

and that is all, execute again ./qDslrDashboard.sh and this should be work.

Regards!!!
That solved the problem for me. At least the GUI shows up for the first time.
Thank you zidqat

lispm
Posts: 10
Joined: 17 Apr 2021, 14:03

Re: Error with qDslrDashboard V3.6.4 for Raspberry Pi 4

Post by lispm »

Unfortunately my Nikon D810 connects but neither LV nor image preview work.

ibirru
Posts: 7
Joined: 26 Sep 2016, 18:11

Re: Error with qDslrDashboard V3.6.4 for Raspberry Pi 4

Post by ibirru »

Hi Hubaiz,
also in my Rpi4 I have the LV and preview black.

The app run well, without any error or library missing message.

Any suggestion to solve it?

I run a Buster 32 bit OS on Astroberry server distribution

I think that qDslrdashboard could be a very useful completion to all Astrophotagraphy suite and I hope that you could collaborate with astroberry developer to include qDD into it.

Thanks

Fabio

skysurfer
Posts: 14
Joined: 24 Mar 2019, 08:31

Re: Error with qDslrDashboard V3.6.4 for Raspberry Pi 4

Post by skysurfer »

I tried it on a non-Raspbarry Pi ARM Linux (Ubuntu 22.04 XFCE as a QEMU VM on a Mac M1), but same issue: nothing happens when I run the start script `qDslrDashboard.sh`. Even after copying the missing libraries in the Qt_libraries folder.

Then I tried it again on a real Raspberry Pi 4 (Ubuntu 20.04 LTS) but the same issue occurs.

Maybe this script is not a generic arm64 Linux script, but specifically for the Raspberry Pi OS ?
Screenshot 2022-05-08 at 11.25.10.png
Screenshot 2022-05-08 at 11.25.10.png (108.18 KiB) Viewed 107 times

hubaiz
Site Admin
Posts: 1976
Joined: 27 Jan 2015, 18:58

Re: Error with qDslrDashboard V3.6.4 for Raspberry Pi 4

Post by hubaiz »

The Qt libraries where built with Raspbian OS, so it will only work with it.

Post Reply