Nikon D5300 connects to Android via USB, then disconnects

Open discussion about photography, qDslrDashboard
Post Reply
Kevin256
Posts: 1
Joined: 15 May 2021, 09:11

Nikon D5300 connects to Android via USB, then disconnects

Post by Kevin256 »

Hello,

I'm trying to connect my Nikon D5300 to my Android phone (running Android 9) using USB. I've tried Camera Connect & Control and qDslrDashboard and in both cases, the camera connects, then disconnects. Camera Connect & Control will even go as far as building an image cache, then will disconnect. I can see the preview for images on the camera after the cache is built, so I know there is a connection at some point that is lost. I can connect wirelessly but would prefer a wired connection.

Does anyone know what could be going wrong?

Edit:

My phone also shows "Media device connected" and "charging connected device via USB". I try to switch hosts and it says "couldn't switch".

Also with dDslrDashboard, I can interact with the camera somewhat. Pressing live view gets a response, but my phone remains black. I can also hear the camera focusing when I press AF. When I press camera mode in the app, my camera shows "connected to PC for a few seconds, then goes back to the main screen. So clearly there is a connection between the devices, I'm just not able to take or view photos.

Edit:

Another unexplained thing. I tried capturing an image in qDslrlDashboard, and get no response until I close the app. Then my camera captures the image.

Post Reply