TP-Link TL-WR902AC AC750 v.3

Open discussion about photography, qDslrDashboard
wlayher
Posts: 33
Joined: 15 Oct 2018, 14:02

Re: TP-Link TL-WR902AC AC750 v.3

Post by wlayher »

Look at the first screenshot for tftpd64 on this page. The drop down menu "Server Interface" is where you must select the correct interface and it should have the ip "192.168.0.66". As soon as the router boots up the progress bar should appear.

Oki
Posts: 8
Joined: 31 May 2020, 09:39

Re: TP-Link TL-WR902AC AC750 v.3

Post by Oki »

That is exactly what I did.I also watched video where everything was explained step by steps but, no progress bar appears in my case. I just hold reset, waiting for it, but nothing. I will try it tomorrow on different computer and let know here how it ended.

wlayher
Posts: 33
Joined: 15 Oct 2018, 14:02

Re: TP-Link TL-WR902AC AC750 v.3

Post by wlayher »

Did you also set the working directory (or "Current directory" as in the screenshot) for tftpd64 to the one containing the .bin file to be flashed? The documentation says that tftpd64 uses the directory where it is installed, but after startup it shows another directory, mostly "C:\temp" and you have to set it again. Better double check this setting.

Oki
Posts: 8
Joined: 31 May 2020, 09:39

Re: TP-Link TL-WR902AC AC750 v.3

Post by Oki »

Of course, directory is properly set, I checked it with "show dir" button, and tp_recovery.bin was listed here.

//Edit: Sorry for wasting of your time, I did mistake. I was filling "196.168.0.66" instead of "192.168.0.66" :oops: I do not know from where I got that 196... Firmware sucessfully flashed now, I am going to try it.

Raj120p1
Posts: 1
Joined: 08 Aug 2020, 08:16

Re: TP-Link TL-WR902AC AC750 v.3

Post by Raj120p1 »

I created the files and recompiled. The second radio shows up now, but only as "Generic 802.11bg". maybe I'm missing the driver. I verified that the config files on the router match the files I created. The only things I changed were the LAN IP and the MAC address.

wlayher
Posts: 33
Joined: 15 Oct 2018, 14:02

Re: TP-Link TL-WR902AC AC750 v.3

Post by wlayher »

Hi, I just updated my configuration to the latest snapshot version of Openwrt. In "make menuconfig" you need to select all the "Kernel modules > Wireless Drivers" starting with "MediaTek MT76x". I have selected those to be compiled into the kernel, not as modules, so as <*> and not as <M>. Modules should work too, but then you have to load them somewhere. I also noticed that in the latest version you can no longer use "00" as a country for wireless. The wireless interfaces appear as active in the status page if you connect to the router via cable, but their SSID does not appear on mobile devices. You have to select a country for this.

Post Reply