Linux version issues

qDslrDashbord error reports
Post Reply
maricn
Posts: 2
Joined: 29 Dec 2021, 12:23

Linux version issues

Post by maricn »

Hi, I just successfully started qDslrDashboard_V3.6.4 x86_64 version on my:

Code: Select all

Linux work-x1c-arch 5.15.11-arch2-1 #1 SMP PREEMPT Wed, 22 Dec 2021 09:23:54 +0000 x86_64 GNU/Linux
1. I can successfully connect with my Sony rx-100m7 via USB, however when I try to modify the shutter speed, aperture or ISO, the dialogs that pop up are empty, they look broken. Also, those three are the only settings that show in the status bar (missing WB, EV, battery level, etc.).
2. So I thought I can try connecting via WiFi - I connect the laptop on the WiFi as provided by the camera, but the logs only show:

Code: Select all

Searching for Sony wireless camera
Found Sony SonyImagingDevice wireless camera, can't connect
Finished searching for Canon/Sony wireless camera
3. OK, back to using USB, let's try LRTimelapse screen - oops. I get a dialog saying:

Code: Select all

Can't enter LRTimelapse screen
- Camera is not in M mode
- Image format is not RAW+JPG or JPG
Ofc, I triple checked the settings, and switched between M and other modes and JPG and RAW+JPG (including changing JPG size settings) but no luck.
4. Taking a photo doesn't seem to produce any image neither on SD card nor in the configured gallery directory on the computer.

The Live Image display works very well and other dialogs (timer settings) are showing correctly, but the app is unfortunately not functionally usable for me. Please let me know if you need more information to debug the issues. Oh, yes, I'm on wayland (swaywm) but that shouldn't affect the issues here as Live Image display and some dialogs work correctly.

hubaiz
Site Admin
Posts: 1977
Joined: 27 Jan 2015, 18:58

Re: Linux version issues

Post by hubaiz »

Sony cameras only work with using the wireless connection using the camera 'Smart remote control' application ( https://www.playmemoriescameraapps.com/ ... _00-F00002 )

maricn
Posts: 2
Joined: 29 Dec 2021, 12:23

Re: Linux version issues

Post by maricn »

Hi hubaiz, thank you for your answer.

Unfortunately my RX-100M7 is not supported by the PMM apps. Their development actually seem discontinued since RX-100M5, and superseded by the Imagine Edge Mobile apps. Unfortunately that app also refuses to connect from my phone. And anyways, I'd like to use qDslrDashboard with it. Is there any effort to start supporting these newer Sony cameras? As far as I understand the RX100M6 and RX100M7 have different OS and API.

hubaiz
Site Admin
Posts: 1977
Joined: 27 Jan 2015, 18:58

Re: Linux version issues

Post by hubaiz »

I began working on it but without proper documentation from Sony it is slow, and I only have the Sony a6300

Post Reply