qDslrDashboard V0.2.5 and updated manual

New qDslrDashboard V0.2.5 with the following additions/fixes

  • added Sky Stacking – it can create series of captures that can be then used in application like DeepSkyStacker
  • added a simple Rule 600 calculator dialog
  • moved Custom Bracketing to a separate display
  • added option to start Custom Bracketing with shutter speed set to BULB (the camera must support BULB capture)
  • added option to Custom Bracketing to use BULB for shutter speeds longer or equeal to 1 second (the camera must support BULB capture)
  • add aperture ramping to LRTimelapse
  • added BLV (bright live view) button to live view
  • added 100% zoom to image viewer (single click/touch will toggle between not zoomed/100% zoomed
  • added left/right swipe for image viewer (will display next/previous image)
  • added a toggle button to image viewer that will show/hide the buttons and the quick gallery
  • added some more properties for Sony wireless models and also enabled LRTimelapse
  • added a ‘Connection lost’ audio option
  • added synchronized starting of movie recording (all connected cameras must be in live view and in movie mode)
  • some UI fixes
  • stability fixes
  • updated the manual to reflect the changes

The files can be download at http://dslrdashboard.info/downloads/

I also uploaded the V0.2.5 for iOS devices to Apple for review

28 thoughts on “qDslrDashboard V0.2.5 and updated manual”

  1. Yeah.. Work fine with tl-mr3040 and Nikon d300s on my Samsung S4, but crash when active Live view on my asus me302kl.
    Any idea?

    very good job

    1. According the spec. it should be more then enough to run qDD including live view. I presume you use the Android x86 version.

  2. Wonderful app. Been looking for something like this for an age – thanking-you-kindly.
    Trying to find a way to delete image on camera once its transferred to the device (android in my case) – is this possible/ likely to feature?

    1. Np, regarding the image selection you can long press the selection button in the gallery and it will invert the current selection

  3. I get a crash when trying to view NEF files.
    I’m using Android 5.02 (Lollipop). Here is the logcat when the crash occurs. I looks like the application is linked to a library that is not there (libllvm-qcom.so). There is a similarly named library /system/vendor/lib/libllvm-a3xx.so so so perhaps the linking changed for lollipop.

    I/Adreno Profiler(11719): Using libraries from system partition
    I/Adreno Profiler(11719): Using libraries from system partition
    I/Adreno Profiler(11719): Using libraries from system partition
    W/Adreno-GSL(11719): : os_lib_map error: dlopen failed: library “libllvm-qcom.so” not found, on ‘libllvm-qcom.so’
    W/Adreno-GSL(11719): : os_lib_map error: dlopen failed: library “libllvm-qcom.so” not found, on ‘libllvm-qcom.so’
    W/Adreno-GSL(11719): : os_lib_map error: dlopen failed: library “libllvm-qcom.so” not found, on ‘libllvm-qcom.so’
    E/Adreno-GSL(11719): : GSL MEM ERROR: kgsl_sharedmem_alloc ioctl failed.
    E/Adreno-ES20(11719): : gsl_device_waittimestamp failed in rb_timestamp_wait_on_timestamp
    W/Adreno-EGL(11719): : EGL_BAD_ALLOC
    W/Qt (11719): (null):0 ((null)): QEGLPlatformContext::swapBuffers(): eglError: 12291, this: 0xaf962070
    W/Qt (11719):
    E/Adreno-ES20(11719): : Fail to submit the command because of out of memory
    W/Adreno-EGL(11719): : EGL_BAD_ALLOC
    W/Qt (11719): (null):0 ((null)): QEGLPlatformContext::swapBuffers(): eglError: 12291, this: 0xaf962070
    W/Qt (11719):
    W/Adreno-EGL(11719): : EGL_BAD_ALLOC
    W/Qt (11719): (null):0 ((null)): QEGLPlatformContext::swapBuffers(): eglError: 12291, this: 0xaf962070
    W/Qt (11719):
    W/Adreno-EGL(11719): : EGL_BAD_ALLOC
    W/Qt (11719): (null):0 ((null)): QEGLPlatformContext::swapBuffers(): eglError: 12291, this: 0xaf962070
    W/Qt (11719):
    E/Adreno-GSL(11719): : GSL MEM ERROR: kgsl_sharedmem_alloc ioctl failed.
    F/libc (11719): Fatal signal 11 (SIGSEGV), code 1, fault addr 0x14 in tid 11793 (QtThread)
    I/DEBUG ( 222): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
    I/DEBUG ( 222): Build fingerprint: ‘samsung/jfltetmo/jfltetmo:4.4.4/KTU84P/M919UVUFNK2:user/release-keys’
    I/DEBUG ( 222): Revision: ’10’
    I/DEBUG ( 222): ABI: ‘arm’
    I/DEBUG ( 222): pid: 11719, tid: 11793, name: QtThread >>> info.dslrdashboard <<<
    I/DEBUG ( 222): signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x14
    I/DEBUG ( 222): r0 00000100 r1 7c000000 r2 00108000 r3 03000108
    I/DEBUG ( 222): r4 af658024 r5 00000000 r6 af6abe40 r7 9e08b000
    I/DEBUG ( 222): r8 9e0aa000 r9 00000001 sl 00000004 fp 00000000
    I/DEBUG ( 222): ip 00052200 sp 9deee868 lr 28000250 pc ab61d7da cpsr 60000030
    I/DEBUG ( 222):
    I/DEBUG ( 222): backtrace:
    I/DEBUG ( 222): #00 pc 000aa7da /system/vendor/lib/egl/libGLESv2_adreno.so
    I/DEBUG ( 222): #01 pc 000abd03 /system/vendor/lib/egl/libGLESv2_adreno.so (oxili_loadexecutable+234)
    I/DEBUG ( 222): #02 pc 0007cd81 /system/vendor/lib/egl/libGLESv2_adreno.so (rb_gpuprogram_loadexecutable_internal+24)
    I/DEBUG ( 222): #03 pc 00053f43 /system/vendor/lib/egl/libGLESv2_adreno.so
    I/DEBUG ( 222): #04 pc 000544c1 /system/vendor/lib/egl/libGLESv2_adreno.so (core_glDrawElementsInstancedXXX+392)
    I/DEBUG ( 222): #05 pc 0005461d /system/vendor/lib/egl/libGLESv2_adreno.so (core_glDrawElements+10)
    I/DEBUG ( 222): #06 pc 00043c73 /system/vendor/lib/egl/libGLESv2_adreno.so (glDrawElements+28)
    I/DEBUG ( 222): #07 pc 000a3af5 /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so (QSGBatchRenderer::Renderer::renderMergedBatch(QSGBatchRenderer::Batch const*)+1016)
    I/DEBUG ( 222): #08 pc 000a42b5 /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so (QSGBatchRenderer::Renderer::renderBatches()+660)
    I/DEBUG ( 222): #09 pc 000a7f6f /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so (QSGBatchRenderer::Renderer::render()+1926)
    I/DEBUG ( 222): #10 pc 000aac31 /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so (QSGRenderer::renderScene(QSGBindable const&)+236)
    I/DEBUG ( 222): #11 pc 000aadb7 /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so (QSGRenderer::renderScene(unsigned int)+30)
    I/DEBUG ( 222): #12 pc 000b1d5f /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so (QSGRenderContext::renderNextFrame(QSGRenderer*, unsigned int)+66)
    I/DEBUG ( 222): #13 pc 000d2f2d /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so (QQuickWindowPrivate::renderSceneGraph(QSize const&)+320)
    I/DEBUG ( 222): #14 pc 000bf82f /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so
    I/DEBUG ( 222): #15 pc 000c15c3 /data/app/info.dslrdashboard-2/lib/arm/libQt5Quick.so
    I/DEBUG ( 222): #16 pc 00077621 /data/app/info.dslrdashboard-2/lib/arm/libQt5Core.so
    I/DEBUG ( 222): #17 pc 0001392f /system/lib/libc.so (__pthread_start(void*)+30)
    I/DEBUG ( 222): #18 pc 00011a0f /system/lib/libc.so (__start_thread+6)
    W/ActivityManager( 553): getTasks: caller 10101 does not hold GET_TASKS; limiting output
    I/DEBUG ( 222):
    I/DEBUG ( 222): Tombstone written to: /data/tombstones/tombstone_01
    W/ActivityManager( 553): Force finishing activity info.dslrdashboard/com.dashboard.qdslr.DslrDashboard
    I/BootReceiver( 553): Copying /data/tombstones/tombstone_01 to DropBox (SYSTEM_TOMBSTONE)

      1. The device is a Samsung Galaxy S4 running Cyanogen Mod 12 (5.0.2 Lollipop) (although the line from build.prop does say ‘‘samsung/jfltetmo/jfltetmo:4.4.4/KTU84P/M919UVUFNK2:user/release-keys’ (as shown in the logcat above) it is actually Android 5.0.2) .

          1. I tested a D750 NEF file on the Nexus7 with Android 5.0.2 and it worked fine. Could be that CM has not yet included all the default libraries.

  4. Hi Zoltan,
    thank you for the new features regarding custom bracketing which is not able to use bulb. The bad news is, that the app is quite prone to crashing when using them. At the moment I only checked it on Android device since the iOS version is not yet out.
    Anyway during one of the crashes I captured the logcat output of my phone. Maybe it will help you track the source of the problems.



  5. I made a small typo in my previous post. “not able to use bulb” should read “now able to use bulb” 🙂

  6. Hi Zoltan,
    Love the application but am having some issues with the AF feature in particular. Am running android 4.4.2 with a TP link router and Nikon D7000. Auto Focus seems temperamental and doesn’t always work. Is there a way to select the focal point in the frame?

    1. Can you explain the problem? qDD does not focus it just sends the focus command the camera and the camera does the focusing.

  7. I have a D3300 and i tried the V0.2.5 on my MOTO G (5.0.2). I got the app not installed error. And I was getting a blank screen with app available on play store. Can you provide a fix for this Zultan , I am super excited about this app especially with new added features.
    Thank you

  8. Hi, I firstly have to congrate you Zoltan for the great job done with this app! I am a newbie with it and trying to get all the functionalities. I’ve used it with a Nikon D3000 and Ubuntu 14.04 LTS/Android as hosts, have not found issues in the machine with linux but not been able to use “interval shots timer” function with android. I use a nexus5 wich has OTG function, I can capture a single shot but when trying to do more than once, the camera do it once and then stops and the app shows “capturing image” indefinitely… This happened with 0.25 version, I then tested the version found on the playstore and it works well… Any idea about why is this happening??
    Thanks in advance and congratulations again!

    1. The Nikon D3x00 models are budget models with limited set of PTP commands/properties. I’m trying to make them work as best I can but there is no documentation from Nikon and I don’t own any of them.

  9. Zoltan, I had a problem using USB with my D7100 in ver 2.04 and had to revert to 2.03 for it to work. I using a Samsung Galaxy Note 10.1 running 4.1.2. Did v2.05 address this problem?


  10. Made a little donation, its not much but will give more in the future.

    Thanks for the BLV and the 100% Zoom! Need it all the time and had to use a different app previously.

    Here some ideas on Zoom (in image gallery):

    It would be nice to have a 200% Zoom as well, since on new tablets the pixles are so small and tight together that it is hard to judge the crispness of the picture in 100% view alone.

    It would also be great to have something like a “Zoom and Pan Lock” option: when comparing images, the zoom would stay on the chosen value and the display would show the same area of each image when browsing throuth them. This would greatly help to compare the technical details of a set of images.

    If i may make one more suggestion, my colleagues and I often view the image at a decreased zoom level (smaller than the screen size) to get a feeling for the composition of an image, so that would be very nice too.

    Concerning the new Version 0.2.5:
    For some reason in Live View mode the grid mode, aspect ratio and flip mode dont work. I can press the button and typ in a change, but it doesnt apply.
    Is it just me or does anyone have the same problem?
    I´m using a Galaxy Tab S 12.2 and Nikon D7100/D800.

    Again thank you very much for your great work!!!


    1. Thanks for the donation. 🙂
      Will see to add 200% zoom.
      For the ‘Zoom and pan lock’ will see if I can add it.
      The live view grid, AR buttons will be fixed in the today quick fix release (V0.2.6)

  11. hi!
    many thanks for adding the suggested 100% zoom option in review. your continuos support and quick answers are very appreciated!
    greetings from italy

  12. Does anyone here have any experience with connecting 2 cameras using 2 different MR3040 Routers? Both cameras are identical (Canon 7D). Both MR3040’s have been updated with the latest firmware. I believe the new router needs to be setup as a repeater off the first router -but am not sure exactly what to set. If someone can help me soon -(I have an important 2 camera shoot next week and need to get this working quickly).

    1. I already answered you in email, but here is a link that could help you: http://wiki.openwrt.org/doc/howto/clientmode
      You can do the configuration from the OpenWrt web interface.
      You would leave one MR3040 as is, this will be the AP, you would connect your Android/iOS/PC device to it and the second MR3040.
      On second MR3040 you would need to change the LAN IP address say to (Network->Interfaces->LAN) and set the wifi to client mode (Network->Wifi and then press the ‘Scan’ button – the AP MR3040 should be turned on – and finally the ‘Join’ button)
      Probably before doing this you should change the AP name and wireless channel on the MR3040 that will become the client (not sure if needed)

Comments are closed.