qDslrDashboard V0.3.3

qDslrDashboard V0.3.3 is now available for all the supported platforms.

Starting from this version the Android version is available from the Google Play Store.
Also the Android version isn’t free anymore (one reason for this change is that I’m still unemployed and the second reason is to make it equal to the iOS version)

For the Raspberry Pi 2 version the latest Raspbian (Jessie) image was used. You must use the raspi-config to set 256MB memory for the GPU.

On OSX El Capitan the only way I could get USB working was by executing ‘sudo killall -9 PTPCamera’ after the DSLR was connected with USB (hope there will be a better solution in future)

I also got reports that there is still a problem on iOS version with the Canon 5D MII DSLR (changing focus point in live view will crash the application) that I will address with a quick fix.

In V0.3 version I rewrote most of the core classes and fixed lot of the stability problems present in V0.2.9
Also reworked the UI and it should be faster now including live view.
New in V0.3 is the NMX control screen and the interval controller.

The NMX screen can be used for controlling the Dynamic Perception NMX Controller. On Android and iOS it can be controlled using Bluetooth, on desktop versions the USB connection (USB serial connection) can be used.

The Interval Controller (IC) can be used to create advanced interval captures using the NMX Controller and connected DSLR cameras.

23 thoughts on “qDslrDashboard V0.3.3”

  1. Hi Zoltan ……

    Great you will have more time to address the fixes we need for all platforms now that you are unemployed you will have more time on your hands to get these fixes done in a quicker than normal manor which you have been addressing these faults .
    We the people using this app or program just want a quick fix on what we find broken ……I have seen apps on the Apple Store within a 2 or 3 day turnaround back up and ready for a download if you have to pay extra for that service I don’t know but you might be able to address the slowness of the turnaround problem between fixes only for the app to be still broken .
    It is good you are asking money for the android version it will help put food on the table and pay bills for you …….but for us still a broken program that don’t work like it should .

    Now let’s take it like I have not been here before I buy your app based on what it says it can do I then spend loads of $$ to buy a canon 5D mark 3 ,a lens ,memory card ,filters, and a TP-link MR-3040 router with hope of doing video and saving it to my android or iPad which was yet another purchase .
    I than try it out and I am disappointed it did not do as the app said it would it crashes time and time again I let you know you make a fix put it up on the Apple App Store I wait near a mth only to find out it won’t work I tell you again and the same thing goes on mth after mth after mth while I am left with all this camera gear to do nothing till you make a REAL fix for this app and have it working like it should …….now let’s hope you can borrow a Canon 5D mark 2 and 3 and a Nikon D810 of course you have a Canon 70D I can see that’s why the video recording works on PC and the canon 5D mark 2 and 3 don’t ….As a thought of you can’t borrow the cameras ….HIRE them we are now paying for the app use that money to hire them spend a day on each camera till you have this app fixed .
    Oh also the focus problem as well needs fixing …..
    I am sure if you were in our boots (Shoes ) you would want a app that you paid for to work stop winging it and do the testing once it works with all feature like you have advertised then put it up on the app store so we can use it with out it breaking 30seconds after I download it …..Now you have plenty of time being unemployed you should have a fix for it soon …..oh I returned the iPad pro got my $1499.00 back because you app is still is broken.

    If you can’t borrow or hire the cameras or gear save up $ for a plane fare to Australia and you can use all my camera gear to test with your programs and apps that’s way I finally might have a app that I have paid for to work like it should .
    Please don’t disappoint me and all the other people that have paid for you app …..Fix it !

  2. From the forum are a copy and paste !

    just got 0.3.3 from the App Store and Well don’t hold much faith in the Next version from the App Store it is still broken as well .
    The app starts ok hit the screen to focus it will focus now but tap the iPad screen to refocus on a different area and the app crashes and blows out !
    if you have the lens set to auto focus change the focus point and it blows out …..WTF waited 3 mths for this fix ……measure twice cut once didn’t apply here need this fixed now and a new version on the app store !

    Canon 5D mark 2 and MR-3040 4th gen iPad
    Same results on the iPhone 4s

    Also movie recording won’t record if you are in manual mode on the camera only in Auto mode on the camera ….no recording saved to iPad as well .

    When will all this be fixed ? Don’t you test all this first before uploading to Apple ?

    So yet another 14 plus days before the next version on the Apple App Store !

    Also on the android version no movie recording in manual mode only works in camera auto mode VERSION 0.3.2 ( TheFREE version )…….

    On another note to those people with magic lantern on their cameras don’t run magic lantern as you will get funky results and lock ups I always test with a clean memory card with no magic lantern on it .

    Some more testing 70d does not have a problem on 0.3.2 on PC 64 bit for video recording while in manual mode auto focus is good also …a quirk but sometimes you click on the AF button it will bring up the ISO range for you to select a ISO ???? Whats going on there while connected to the mr-3040 .also in auto and can download and watch it .

    Canon 5D Mark 2 won’t record in manual mode on PC either !

    Now go to android with the 70D and the Mr-3040 connected it will record in manual or auto camera mode but can download the movie but nothing happens and some weird graphics problem comes up the player comes up to play the movie but nothing happens …….Samsung galaxy note 2014 kitkat .there are some problems to fix Qdslrdashboard ver 0.3.2 android.

    Just more info so you can fix it quicker and better .

    I am going to buy the Android version now from the Google play store ………I bet I can break the app in less then 10 seconds ….
    How do I know ….I just. Do !

    1. Well set my canon 5D Mark 2 up manual mode on the camera dial with the TP-Link Mr-3040 went o the play store bought the app downloaded it connected to the MR-3040 started the Android App Qdslrdashboard ver 0.3.3 hit the movie in LV button hit record . And you guessed it under 10seconds and it don’t work so closed the App off back to the App Store to hit the REFUND button …….
      Moral of the story why pay for something which is broken …. I will pay for a app if it works not a app that don’t wasted my time yet again …..

      If you fix it I will pay for it !

  3. You know Cathy, as much as you have a point, you forget that without the developer you would have nothing. If you want reliable, fast, and great customer service. Pay for it! So You always have the option to buy a CamRanger for $300 or you can support a developer who is giving us an alternative. When I downloaded my first free version I donated money and when I got my las android one I was happy to pay for it. Maybe if we put more money into Zoltan’s efforts he can hire someone to help him. The guy deserves better.

  4. Spot on Gerry. I also donated towards this app and use it with a Canon 6D and Nexus 7 with the 6D wireless option and it works great albeit I only shoot for photography not video.
    My only question here is though as I already donated do I have to pay the full price for the app again or is there an update option of payment?

  5. Ok you fellas well I paid for the Apple app it don’t work I have spent my time in letting them know what is wrong with the app on a lot of different cameras platforms and wifi units do I get paid for my time NO so you spend the time and put what is wrong with the apps and so forth and put your shutter count up and loose sleep doing so .
    Go buy a tv tomorrow and if it don’t work sit at home and work it out or do you take it back and get another …..yes I would take it back and get another ….moral of the story if I buy it should work out the box …… So the app should work correctly before being posted on here I would pay $50 Aussie dollars if it worked like it should but it don’t and camranger I have 2 already for other jobs Qdslrdashboard was for other projects with I have been helping of different errors but taking so long to fix …..sounds like you don’t heavenly test the app otherwise you would have found the faults before I did !

  6. Hi, As I said I only use the app for still images so no reason to test other options. I started with DSLR Controller from chainfire and due to the not lack of updates with but for more than two years zero updates and no more as the developer has given it up. For what QDSLRDashboard does it is well worth the money IMO at least Zoltan Hubai is trying to get the best app he can with very little resources.
    For what it costs I cannot see a problem price wise.
    If you have two Cam Rangers and are happy with them then why spend your time and money on what you don’t like just buy another Cam Ranger that is just gloryfied 3040 with there software installed.

    1. Cuz I have 2 mr-3040 and a Hame programmed for Qdslrdashboard the other the 2 camranger are for other cameras …..I have 5 cameras in total and each camera has a job to do so 3 of the cameras are for Qdslrdashboard and the other 2 are for the camrangers with the motors ..I would pay $50 right now to Zoltan if it worked like advertised as I have paid that kind of money for sky safari pro4 for iPad and android as they do as they say they do …..just want a fix for the app so I can get to the job on hand I have set aside for the app.

  7. Cathy, I guess, is more a matter of how you are addressing the situation. It doesn’t seem you are appreciating the guy’s efforts and you seemed to just demand. The guy is disclosing to us that he doesn’t have a job and you feel the right to tell him what to do with his time? You have a fallen soldier and you still kick him in the ground? So I get it. Just show more respect that’s all. I do know that feedback is needed to the further development of the software, but is like I always say. Is not what we say, but how we say it. I hope Zoltan can make money out of this and this software gets completely polished.

  8. Gerry I hope Zoltan makes a fortune out of his apps my complaint is the turnaround time between fixes there has to be a way to get the app from Apple quicker so we can test it and let him know what’s wrong so he can fix it other wise it’s a game of ping pong …the only way to get it fixed quicker if he has people close by with cameras he can use to test …..so to get the app fixed quicker …I have said he can test with my camera gear if he wants to come and spend some time here free board and food !the offer is there for my help to help him …….so anyone near Zoltan can stand up and help ? I willing to help this fallen soldier !

    1. Cathy, absolutely, people who bring feedback are valuable. I’m in the same boat, we both want this to be the best app ever.
      Now I’m going to test it extensively. I’m planning a trip to iceland and I’m hoping everything goes well. I shoot mostly stills.

  9. Yes Gerry we all want this app to be the best there is on the market.
    I done a bit more testing but I did it with the Nikon D810 with a TP-Link MR-3040 attached with a iPad 4th gen and qdslrdashboard 0.3.3 tried video recording in liveview in auto and manual mode it records but it downloads to the iPad and the movie player comes up but 0 time on it and cannot see the file so that need to be fixed.

    Now the same camera and wifi but Android Qdslrdashboard 0.3.2 Samsung galaxy note 2014 Edition with kitkat and movie records in manual mode and auto mode on the camera dial
    Files are recorded and you can play the video files back but no sound so more fixes needed there ….

    In my other rants you can see I tested the canon 70D with the mr-3040 and the canon5D mark 2 with the same type of results no video recording in manual mode on the canon gear only in auto mode on the dial and video recording did not work …so that needs attention as well on android and iOS .

    Yes we are also wanting to go to Iceland as well but all this gear has to be working before we go .

  10. Canon ,Also the video recording on the iPad downloads but you can’t find it the player comes up 0 time ?
    Don’t know where the file went ?

  11. So be grateful that Zoltan wanted to develop qDD and did not left it after he did what he needed – besic remote control for Nikon.

    And for your so wasted time on testing qDD – if you could just spent 10 minutes on searching if Canon is good option for remote controlling, you would found that it is not because there is no widely available API and every function has to be cracked.
    And also there is no API at all for mobile systems…

    And for the video playback – qDD is not a video player so if there is no sound use video player or system that supports this movie format.

  12. I am grateful he continued to develop it for other platforms as well !
    I see Mac users out the Windows platform users and more than likely android and iOS as well because over 8000 Mac downloads of version 0.3.3 the latest .

    And for video with Sound playback yes on the Free PC version it works on a 70D with a Tplink router but not on the iOS or android the paid versions

    And the time I have spent testing ….Zoltan has been able to fix the problems with it …..I did see other people putting there hand up and letting him know the problems that They found so he can verify the faults that I had were the same as they had …
    If we had more fault finders the app may be fixed quicker . And need a way test the iOS app quicker the a 14 day turnaround only to find out it is still broken and another 14 day or more turnaround to test again if it was a 1 or 2 day at the most would help a lot to quickly report back have a fix done test and report back ….. 2 upload a mth is all we are getting if someone lived around the corner from him could help test on there cameras or iPad PC whatever it may get fixed quicker.
    Any body out there live close by that can assist ?

  13. For the iOS deley you can blame only Apple.
    They alwyas treated small developers like garbage and did not make solid testing platform.

    The video/audio playback problem is only on system side and Zoltan cannot do anything about this.
    MOV is Apple’s QuickTime format that is natively supported only by OSX and without proper codecs you cannot play it so no playback on iOS until Apple will allow it.

    Also some Android devices (eg. Lenovo tablets) can play mov file but they have system modified by Lenovo not plain Android like on Nexus devices.

    And finding this all took me 5 minutes with Google. So stop blaming Zoltan for all the evil in the world because most of the answers you can find with in seconds.

  14. Yes. Agree Apple is slow but you are missing the point someone close to him could assist so it does not take so long .
    Ian sure someone out there close to home could assist .
    If he was here in Australia he would have access to all my gear and I could get a few different models from friends for him to test and finally have a completed app that would not disappoint .
    And also make the $ on

  15. I have a peoblem with connecting my Nikon D5300 via OTG with the dogee valencia DG 800 and Flamefox Smart both running on android 4.4.2. What I’m doing wrong?

    1. Check if those phones have full USB-host capability – use app called “USB Device Info”, connect camera and check if it is seen under both tabs: “Linux” and “Android”.
      If under only one – your phones do not have proper USB-host functionality.
      If is not seen under any – you have wrong cable or your phone does not have USB-host at all.

  16. It looks like iOS 9.2 is bringing DSLR photo copying using the camera connection kit USB adapter to the iPhone. Hopefully they also allow other USB functions to allow qDD wired connection for iOS.

  17. The Raspberry Pi Version is working great. After reading the Forum it takes very less time to get it running on the Touchscreen and/or HDMI Panel.
    But is there any possibility to get the screen to an VNC Viewer? I tried tightVNC, RealVNC, x11VNC without success 🙁

    BR Markus

Comments are closed.