A user pointed me to the HAME MPR-A2 portable wireless router and after checking that OpenWrt works on it I ordered one from here:


After around 1 month it finally arrived.

The OpenWrt images (with ddserver) are here:

HAME MPR-A2 uImage

HAME MPR-A2 sysupgrade

You need both images, first the ‘uImage’ is flashed using the original HAME administration interface and after that using the OpenWrt administration interface the ‘sysupgrade’ image is flashed.

I wrote a small flashing instructions : HAME MPR-A2 flashing instructions

Here is an image compared to TP-Link MR3040 (V1)


43 thoughts on “HAME MPR-A2”

  1. Hi are you going to make a video for the “HAME MPR-A2”
    like the TP-link MR-3040 firmware install on YouTube ?
    It Will help with the install and make it easier to follow you along at the same time .
    Thanks in advance !
    Ps I have told a lot of people about your IOS software !
    they were most impressed with it on my iPad and what it does.
    Also if you want I can send you a Bluetooth device but you will have to get a skywatchers merlin mount from someone over your way maybe some looking at this forum can assist you in a letting you use their merlin for testing.

    1. The problem is that I already flashed the A2 with the OpenWrt, will see if I can revert back to the original Hame firmware (not sure how as no info about that on OpenWrt page)

      1. I just bought the Hame A2 and I’m going to flash the OpenWRT firmware. I’m also curious if we’ll be able to revert back the original firmware just in case we need to.

        1. Unfortunately, I bricked my Hame A2. I followed the instructions and flashed the first file using the the Hame administration interface. After I waited for the device to restart, it never came back up. The LED is now red and there is no wifi hotspot broadcasted. I searched and the only way I found to un-brick the router is by soldering to the serial connection and connecting to it. That is a bit out of my technical capacity. Do you have an idea why my device got bricked and how to recover from it?

          1. Did you flash it over wired connection or wireless? You should do it over wired connection as after flashing the OpenWrt image the wireless will be disabled.

          2. I was not paying enough attention to the guide and I flashed it while in wired connection. 🙁

          3. Ok, then connect the flashed HAME to your laptop or pc with wired connection (should be the only network connection) and you should be able to continue the flashing and finally to enable wireless.

          4. I think it might be too late because I tried some other things to fix the router and I think I really bricked it for good. I’m going to try and have it replaced but I’m now quite scared to flash the replacement unit.

            Just to diagnose what happened wrong, when I flashed the uImage file, my router restarted and had the red LED light. That was when the wireless became unavailable. Is the red LED really normal and part of the process? If I had connected the router with a wired connection, could I have actually continued? Or did the red LED mean that the flashing was unsuccessful. Maybe the binary was incompatible?

          5. There is nothing to be afraid, if it is an A2 then the file is ok. I still think that you should try it with wired network connection and access it from the browser at
            Just be sure that your PC/Laptop is only connected to HAME.
            My also has red light when I turn it on and only get a blue light when it boots and enabled the wireless (around 30-45sec).

          6. It worked!!! Thanks so much. Off to get the iOS app. Hope it works well with the Canon 100D. Thanks for your awesome work!

  2. Which one works better, the Hame MPR-A2 or TP-Link MR3040? I’m deciding which one to buy. I saw that the Hame is a bit cheaper from a local store.

  3. Might be a few $ cheaper but the battery is only 2000Mah but the Hame is 5200 Mah which will last longer !

  4. Got my Hame Router in the post programmed it up with the firmware and started qdslrdashboard clicked on the network tab and nothing pressed on the 10 times in a row and nothing I had to press and hold the network tab and a seperate box with the IP address would come up I hit connect and it worked.
    Disconnect and try again same thing ……
    Zoltan anyway of fixing this so when you click on the network button it starts and connects ?

    1. Yeah that also happens on my Hame A2 with the Canon 100D. I need to hold the Network button and connect to the IP.

        1. Just tested with my A2 and it works without long press.
          Enter the OpenWrt administration page (
          Under Network->Interfaces click ‘Edit’ for the LAN interface
          Check if ‘IPv4 gateway’ is set (should be
          Check if ‘IPv4 broadcast’ is set (should be
          If not then enter those values and press the ‘Save & Apply” button in the lower right.

          1. Thank you Cathy for ask and Thank you Zoltan to fix. I have the same problem after flashing Hame. After follow Zoltal suggest. I can connect qDslr without long press now. (I also delete all WLAN from Interfaces page and reboot Hame before it work. Not sure if it relate to the problem )

  5. Thank you Cathy for ask and Thank you Zoltan to fix. I have the same problem after flashing Hame. After follow Zoltal suggest. I can connect qDslr without long press now. (I also delete WLAN from Interfaces page and reboot Hame before it work.)

  6. I Entered the OpenWrt administration page (
    Under Network->Interfaces click ‘Edit’ for the LAN interface
    Check if ‘IPv4 gateway’ is set (should be
    Check if ‘IPv4 broadcast’ is set (should be
    If not then enter those values and press the ‘Save & Apply” button in the lower right.

    (Also deleted the wlan ) as IkunI did !

    on ipad when i press it comes up as says

    no dslr device found on ddserver at but it connects and starts Lv .

    on android tablet it says

    Connecting to NIKON DSCD810 ON DDServer but it connects and starts Lv .
    Zoltan anyway of fixing the ipad version to say the same as the android version ?

  7. Any fix for this yet it’s been over a month since the last post about this problem ??

    1. Sorry was on vacation but I already answered the question, qDD always display the shutter speed that is currently available on connected camera. What exposure mode is selected on camera? Is it in live view movie mode or photography mode?

  8. Hi it was in photography mode ! And in that mode you could not select lower than 1/50second but on later s5 Samsung phone with lollipop will go to lower shutter speed right down to 30seconds
    You can read what was said above in my messages try this yourself ….. Would like to use a slower shutter speed of say 10 seconds but it will not display any lower than 1/50 of a sec using a Samsung note 2014 edition with kitkat and qdslrdashboard version 2.9 …won’t do it on my iPad retina 4th version with iOS version 8.4 with qdslrdashboard version 2.9
    Why is qdslrdashboard not displaying lower than 1/50 second on a iPad or Samsung note 2014 but will on a s5 phone with lolly pop ?please test with a Nikon d5300 yourself !

  9. I bought the hame mpr-a1 because I could not find any seller of the a2, and I do not need the bigger battery.

    My problem is when I try to upload the uImage file (openwrt-ramips-rt305x-mpr-a2-initramfs-uImage.bin) I get this error message :
    “Warning: the image file (0x3eada7) is bigger than Kernel_RootFS MTD partition. Not a valid firmware.”

    Google points me to pages saying I need soldering, extra memory, serial communication etc. Have I wasted my money on the a1 ?

  10. Would the MPR-A1 work the same way?

    As far as I can see, it’s the basically the same, just a bit smaller/weaker.

  11. Do you think this modem will work ?
    D-LINK Wi-Fi AC750 Portable Router and Charger DIR-510L

  12. Had all sorts of issues using qDslr on my iPad. Downloaded app on my old iPhone 4s – works flawlessly !
    I guess its work-in-progress. Great software using TP Link, D800e and LRTimelapse Holy Grail.

  13. Hello just came across this interesting page… was googling and got part of what i was looking for.

    I appreciate if you can help i have the same device same chip but different branding. I tried to flash the 1st image wired and now my device only turns red and cant find its ip to recover.

    Only turns red and if i click the reset button and turn it on at the same time it will turn blue.

    can you help plz? thanks

  14. Any idea if this will work with the sony a7rII
    I don’t care about settings etc. the only thing I want is shoot tethered without cables.

    For location workshops the cables can be a real hassle and camranger doesn’t offer a sony version.

    Or does anyone else know of another way to get a connection without using the sony app inside the camera? (The EVF is off in the app).

  15. Hello,
    I have a HAME MPR-A2 Wi-Fi Router/Powerbank.
    I need to configure this device but the password indicated on the back does NOT allow me access to the device.
    How can I reset the device to factory default?
    It it possible to reset the password only?
    Please advise.
    Thank you and kind regards, Hans.

  16. Hello,
    when I saw your web page, I thought that it was a good idea to update my MPR-A2 firmware to WRT. But I am novice. And after many reading, I can’t use it easily. euh I can’t use at all because I am not confident with basic network knowledges. So I wonder if I can go back and to reinstall the original firmware. Of course I did not get backup. Can you help me?

Comments are closed.