qDslrDashbaord V0.2.7

V0.2.7 changelog:

– fix RAW+JPG error when entering LRT for some Canon models
– add D5500 missing property values
– Rule600 dialog save values on exit
– Rule600 dialog link camera focal length (Nikon only)
– DOF calculator dialog save values on exit
– DOF calculator dialog link camera aperture and focal length (Nikon only)
– add image format filters (all, jpg, raw) to image viewer and capture history
– add image EXIF data display to image viewer and LRT image viewer
– add ‘lock zoom and pan’ option to image viewer
– faster thumb extraction for local images in image gallery
– add Canon mirror up capture
– add mirror up delay for Canon (Off – user initiated, 1s, 2s, 3s)
– add Nikon capture delay button to left buttons
– add live view record button
– fix property dialog not positioning on current value
– add cross hair option to live view (off, single, double)
– other small fixes

Submited V0.2.7 to iTunes for review.

I also added Raspbery Pi 2 package. I only tested it with the Raspbian image. The graphics memory must be set to 512 with the raspi-config utility.

245 thoughts on “qDslrDashbaord V0.2.7”

  1. 0.2.7 on Yosemite immediately crashes after start

    Thanks and regards, Bernd

    1. Just spent $9.99 at the iTunes store for DslrDashboard V0.2.7. Web site says it supports the Nikon WU-B1 wireless adapter, which is what I use on my Nikon 1 V2 camera. When I load the program on my iPhone 4S (running iOS 6.1.3) and launch the DslrDashboard program and try to connect to my camera, the program immediately crashes. I have made sure my camera is on, the WU-1B is connected and active, and even that my iPhone is wirelessly connected to camera’s wireless network. And still, every time I press the little Nikon connection button in the DslrDashboard app, the app immediately crashes.

      In the twenty times I have tried to connect the iPhone to the camera, 18 times the app crashed, and two times at the bottom of the connection screen, the message reads: “Failed to connect to Nikon Wireless DSLR”

  2. same problem on android tablet, when I switched from 2.0.6 to 2.0.7
    Thanks an regards

  3. 0.2.7 immediately crashes after start
    0.2.6 worked perfect, but I already deleted the old .apk
    Marker: Acer
    Model: A500

          1. Sorry doesn’t work again.
            Android Version is 4.0.3
            Can you send me a link to version 0.2.6?


  4. Me too crash, i use nexus 5, android 5.0.2 and D3100 (i testing the shotter, but the 0.2.6 is wrong… 🙁 )

    1. Update: The app connect camera is OK, but if press shotter button, flash is “Capture in progress” and not working.

      if you fix this bug, I’ll buy you a beer 🙂

      1. The D3100 is a budget model with very limited set of PTP commands/properties and Nikon does not provide documentation for developers for the budget models

        1. The old(not q) dslrdashboard is worked for me, but not compatible Android 5…

  5. HI,
    I installed the 2.7 release on my nexus 7 2012 tablet.
    I only did some connexion tests, it is working correctly with tplink 3040 / canon 6D+ tplink 3020/canon 1100D. only some tests to launch lrtimelapse : OK
    Thank you for this release and the added features

    1. Hi,
      mee too – 2.7 works fine along TP-Link 3040 and Nikon D800.
      NEF and JPG displays normally, histogram looks good as well.
      Thank you a lot

  6. Hi,
    As feed back, the V0.2.7 crashes on my asus TF700t (android 4.2.1). So I go back to V0.2.2.

  7. Hi,
    I have a Nikon D3200, and just installed your App in my tablet. If works fine, except for the “REC” button, that doesn’t show up on the screen.
    Is this normal?
    To photo it works fine, but I can’t make videos…
    Thank you very much.

    1. The D3200 is a budget model and does not have the required commands for starting movie recording that’s why there is no REC button.

      1. Thank you for your reply. Is there anything i can do to have the live view on my tablet, but still be able to push the rec button on my camera? The problem is that none of the comands in the camera respond after the app takes the control… Thank you, again 🙂

  8. More feedback:

    Galaxy s2 + v0.2.6: good
    Galaxy s2 + v0.2.7: not starting
    Galaxy s2 + v0.2.7.1: not starting
    Galaxy s2 + v0.2.7.2: not starting


      1. I’ve got the same problem with 2.7.3. At startup, it states (german phone): “In Ihrer Anwendung ist ein schwerwiegender Fehler aufgetreten, sie kann nicht fortgesetzt werden” (translates to “a severe error occured in your app, it cannot be continued”).
        Reverted to 2.6, everything fine. Took a picture. 🙂

  9. Hi,

    I am using it as provided by Samsung. Android 4.1.2, standard ROM, no hacks, no tweaks.


    1. Hi Zoltan,
      v0.2.7.4 works. Installation, connection and taking a picture was no problem. I will send you a donation.
      Thank you very much

  10. Just tried this software for the first time, but it won’t find our d750. Nikon app works fine. Using a galaxy note 3, stock os.

    1. You use the camera built in wireless? Please exit the Nikon application (or uninstall it) as while it is active qDslrDashboard can’t connect to camera (only one application can control it).
      Then pair your note3 wireless with the D750, start qDslrDashboard and press the ‘Nikon wireless’ button.

    2. When using wifi:
      – enable wifi network in the D750
      – Optional: use the Nikon wireless App to switch to secured WPA2 network in the D750 and then remove the Nikon wireless App again, since it will interfere with dDslrDashboard. At least it did on my iPhone.
      – choose the correct wifi connection in your device and connect the device to the D750
      – Then start qDslrDashboard and connect wireless to Nikon
      – Switch of automatic locking of your screen, since that will disconnect the wifi connection from qDslrDash.
      – Dont walk away too far with your device 🙂 The wifi is not far reaching I experienced.

      For me connecting (version 0.2.5) worked flawless. 0.2.7 on iOS not yet available, so not tested.

  11. Hi Zoltan!
    Is there a possibility to copy settings from one to another camera when shooting with 2 Nikon d5100s which are connected via TP-Link router.
    When synchronize capture is activated the cameras are shooting simultaneously but all the settings i have to change on both cameras one by one. I am working on a 3d-timelapse, so it would be great, if i could control both cameras at the same time. Thanks a lot! greez pat

  12. hi, is there an updated version for ios/ipad. last one in the app-store is 0.2.5.

      1. Sounds great, looking forward to have the app on my ipad 🙂 Great work!

      2. Hi Zoltan, just saw the 0.2.7 update for iOS and immediately made some tests (iPad Air 2, Canon 5DM3, TP-Link ): works all fine and stable – yeah, great, thx!!!

  13. Works perfectly on Nikon D7100 and Galaxy Tab S 10.5.
    Zoom Lock is great! Also love the quick browse dialoge after capture and the file filter in image viewer.

  14. Toshiba t100
    Android 4.02
    0.2.6 worked well on this setup
    0.2.7 three versions tried, all fail. The first version just gives a blank screen, the other two versions give fatal error.
    Any chance of a link to 0.2.6 ?

      1. Great job Zoltan everything good now.
        Thanks for a really great App. Bill

  15. Hi Zoltan,

    thank you very much for your great app.
    I have one serious problem. During a “holy grail” timelapse, DslrDashboard crashed and afterwards I am not able to start it again.
    I have a Macbook Pro with Yosemite 10.10.2 and Dslr Dahsboard V0.2.6.
    I tried to uninstall Dahsboard and reinstall but without success. Everytime I start Dashboard again, the app crashes (the start screen is not available) and I have to “Force Quit”.
    If this could be helpful for you, I could send you the Crash report.
    Perhaps there is a problem with the USB support?
    Is there a possibilty to uninstall or kill the components via Terminal?
    Thank you very much.

  16. Hi Zoltan,

    had crash problems with all version before, too. is running on Android 4.0.4, GT 7510 10.1.


  17. Very very good App. I use it with my Nikon 7100 and custom bracketing works very nice. No other remote control has so many options. Therefore i have donated.

  18. I finally got the software to boot up (V0.2.7.4) on my Asus tablet running Android 4.2.2. Up till that version, I was getting a “Can not load” message and the software would crash. The software connects to the camera, controls the camera but I don’t see any live view on my tablet. Also, anything to do with displaying a captured photo, including automatically displaying them after capture, reading the card etc, hangs the software, goes to black screen and requires a re launch. I tried both of my Nikons and the control functionality works perfectly. But I can’t live view or display any images. Cameras are Df and D750. I’m hoping it’s just a setting on my tablet (it was brand new for this app to run on). Thanks.

          1. Hey, thanks for the update. The live view works now. But automatic image capture review and anything that is supposed to show the photo that was taken makes the screen go black and need a relaunch. When browsing previously captured photos on the card, the thumbnails show up ok. But when you click on a thumbnail the black screen happens requiring a re launch. Thanks.

  19. Hi Zoltan, maybe you could help me with an issue.
    I have 2 nikon D750’s, and i tried to use the 0.2.7 for OSX 10.10.2 (iMac retina) and 0.2.5 on my iPhone 5 (8.2) and on my iPad mini retina (8.2 also). i’m using the internal wifi sistem on D750.
    I can connect with no problem to the camera, I can take still shots, using the AF, works good. but when I’m trying to film is crashing… both cameras, with the app for all 3 devices is doing the same:
    i’m clicking the camera button and after 1 second the d750 disconnect from wifi (from on is entering in off mode) and app is freezing. when i’m looking to what was captured on the sd card, i can see that the 1 second movie exists.

    and also… could you please tell me why i cannot change the settings? (aperture, shutter speed, iso)… i’m changing them into app, but nothing is changing on camera.

    thank you

    1. Unfortunately movie recording and wireless can’t work at the same time. As soon you start movie recording the camera disables the wireless.

      1. Thank you for reply… So, the only choice is usb connection for film?

          1. Sorry to bother again, but i’ve tried to connect the camera to my ipad mini 2 thru usb and i cannot connect it… I know that appleport s not really an usb like for android devices, but please help me, how i can control the camera for filming (not still images) from and ipad or iphone?
            I just want to use the camera on a crane and to control it from the other end… To have the live view in real time and to control the recording. By wifi is excluded because it will not be realtime

  20. Hey, thanks for the update. The live view works now. But automatic image capture review and anything that is supposed to show the photo that was taken makes the screen go black and need a relaunch. When browsing previously captured photos on the card, the thumbnails show up ok. But when you click on a thumbnail the black screen happens requiring a re launch. Thanks.

  21. Hi Zoltan.
    I have installed 0.2.7 and with usb it works fine with my Canon 5D III. But with the TP-Link 3040 V2 it dont works. DDServer OpenWrt MR3040 V2 Factory 0.13 is installed. Connection with my mobil phone is ok. When i push DDServer in the APP i can see a reaction on the bilinking LED but i always get “No DSLR device found on DDServer at
    Thanks for any idea.

      1. Hi Zoltan,
        yes it is an LG G2 (Android) and i use qDslrDashboard_V0.2.7_Android_arm.

        1. Did you pair the Android device wireless with the MR3040 wireless? Can you access the OpenWrt web interface from your Android device web browser at ?
          If you can, under System->Software do you have the ddserver package (should be V0.2-13)?

          1. Start qDslrDashboard and long press the ‘Network’ button and enter and then press the ‘Connect’ button

  22. I have tried it (and several times bevor) but result ist the same: No DSLR device found….

      1. Same result on ipad and Sony Xperia z3compact. Both worked on previous version

  23. Can I get the link 2.6. I can’t seem to keep 2.7 running it just crashes on my tablets. Tried both Samsungs and my Nexus. Seems to maybe be intervolmeter related. I know I didnt spell that right. Using the Canon 5d Mark III and wireless router solution together. So far I have tried all 3 tablets. No error other than it has crashed after about 20 or shots by interval timer. Trying to get a get a sunset right now in SC, but no luck.

  24. Never mind I saved the apk, I found 2.6. Odd I didn’t see this issue with it. I will try 2.6 right now and see if I can pull this off, running out of daylight l ;-).

  25. worked great on 2.6 Zoltan, I will try 2.7 again when I get home… I just couldn’t figure out why it kept crashing. No issue with 2.6 and my setup. It maybe nothing, just odd

    1. Brett, do you have the 2.6 version of the file that I might be able to try? My 2.7 is kinda wonky right now.

  26. With the new GPS in the app does it use the GPS from the android or iOS tablet or do you have to buy a seperate GPS to plug into the camera ?
    I tried it with my samsung 2014 edition tablet and did not see the GPS info in the exif info display

    1. The GPS info can be only added to images that are captured to local device. If you capture to the camera SD card there is no way to add the GPS info to the image.

      1. Thankyou for the update on the GPS I will try tomorrow to local device then copy pic to card and then see the GPS info in it I hope that is the way it works ?

  27. Regarding the black screen issue when displaying captured photos, it happens with jpg, raw as well as jpg+raw. Can I try 2.6 to see if that fixes it? Thanks.

  28. Hi Zoltan,

    Can’t wait to get my hands on this cool app! I am trying to pair up Nikon D800 with iPad for video recording, I don’t mind using wired connections, since my camera will be on a jib/crane all times, what cable do I need to use ? please advise.


    1. On iOS only wireless connection will work. Either with the camera built in wireless (if it has one) or using the TP-Link MR3040 portable router or any other that supports OpenWrt.

      1. Hi Zoltan,

        Just purchased TP-Link MR3040, do I need to update the firmware? I am using it with iphone or ipad. Having some trouble connecting it to my Nikon D800 with wireless. Do you have any instruction on how to connect iOS device. Please advice.


        1. If you have the original TP-Link firmware on you need to update. The latest firmware is always here: http://dslrdashboard.info/downloads/
          Instruction on how to flash the OpenWrt firmware is here: http://dslrdashboard.info/tp-link-mr3040-openwrt-flash/
          OpenWrt firmware instructions is here: http://dslrdashboard.info/tp-link-mr3040-firmware-upgrade/

          Best you connect your MR3040 to your desktop PC with a network cable and check it’s web interface.
          Original TP-Link firmware web interface is at
          OpenWrt firmware web interface is at

  29. hi Zoltan, hi all,

    since nameless I was not able to use the non q apk.
    Zoltan thank you for enlighten me.
    0.2.7 works fine in this config:
    – d750 with build in wifi
    – s3
    – nameless ROM lollipop

    I miss the movie rec, but I understand is a Nikon restriction.

    excellent job Zoltan!



  30. Hi Zoltan,
    After Android, I installed the application also on my laptop, windows.
    Connection also wifi to d750.
    Is fantastic.
    thank you,

  31. 2.74 from the link You gave above made thru a session perfectly. What’s diff?

    1. in V0.2.7.4 the live view recording option is disabled. Not sure yet why, on my Nexus7 2012 (stock ROM) and SG2 (Omni ROM) both versions work fine.

  32. Hi Zoltan,

    thank you very much for this great app.
    I have a Macbook Pro 15 (02-2011) with Yosemite 10.10.2 and Dslr Dahsboard V0.2.7. EOS 7D connected via USB. All worked swell. However yesterday during a timelapse recording the application crashed and now I am no longer able to start te application. After start it opens a black screen and stop and I have to “Force Quit”.
    I tried to uninstall Dahsboard and reinstalling it but without any luck. I uninstalled, restarted my system but everytime I start Dashboard again, the app crashes and I have to “Force Quit”.
    Perhaps there is a problem with the USB support?
    Do you maybe have a solution for this?



    1. If you find a solution to this problem, I would like to know. I have the same exact issue. I have 1 USB that doesn’t detect (in QDSLRdashboard) that the camera is there, but it does detect via OSx. The other one acts normally, but I get a continuous crash. I had a few crashes mid timelapse last version, but this version crashes unpredictably and much more rapidly.

  33. Hi Zoltan!

    Thanks for this great app! I´m trying to get it working with my Canon550D and my SG2 (stock ROM) via USB. I use and can´t get it to work constantly. After a few shots the app seems to loose connection to the cam. Do you advise to install another ROM (Omni e.g.)? Could this be the problem?

    Cheers, Chris

      1. I tried a few different settings yesterday and it seems, that I have to enable “keep screen on” in the app, to get it working correctly. I´ll test a few more times and report the results here 🙂

  34. ProCaster MID007 tablet with Android 4.2.2

    version 0.2.7 wont start 🙁

    Br Juha

      1. hi
        this works sometimes and sometimes cannot connect to D800

        i have ordererd TP-Link router and will try that when get it.

        Also trying IOS app when the router arrives

        br Juha

  35. Hi Zoltan,
    theanks for this great APP. I’ve got some feedback and a recommendation to the Windows Version.
    1. I’m Using a Nikon D5200, USB (no WiFi at the moment)
    2. Optics is Tamron 17-55 F2,8
    3. Tablet is Samsung Galaxy Tab S, 8,4″ mit 2560×1600, running Android 4.4.
    Your Version 0.2.7 works fantastic and I will really enjoy to start my Excel-webcasts with this solution next time. As I’m very thankfull for your APP, I will be a pleasure to Donate. Since I do not use e-Payment, I kindly ask you to send me your Bankaccount and the Donation, you usually get from the participants of your App.
    My still remaining problem is, that I couln’t connect
    qDslrDashboard for Windows with the NIKON D5200.
    The Programm is running and has the same settings, I used on the Adroid Tab. I try to Connect over USB 2 and USB 3, but the programm remains on the connection-screen.
    I’m Using this PC:
    – ASUS AIO, Intel Core i7, 8 GB Ram Nvidia GT 730M
    – Windows 8.1, with all Updates
    I’ve been trying your 32 and 64 bit version but none of them connects to the NIKON.
    I checked the Connection with “NIKON CameraControl Pro 2”; this worked properly but is – as you know – a useless APP.
    What can I do?
    With kind regards,
    Dieter Reimann

  36. Hi Zoltan, thanks for all the work you do for this app!

    I just installed the latest version and the on-screen meter does not seem to change when changing exposure on the camera.

    Samsung Note4 stock lollipop, nikon d5300, onboard wifi

  37. Hi Zoltan,
    Will a Netbook is Intel Atom N450 1.66GHz, 2GB RAM be ok to run Qdslrdashboard ?

  38. Hi, I use Kindle fire hdx 8.9 with android version 4.4.2, and the version 0.2.6 work well on my device, but when I install the latest version 0.2.7 and try open it, it show me a dialog and says “Fatal error”.

  39. Hi Zoltan,
    Version 2.7 did not work on the Sony with Android 4.1.1 .
    Version 2.74 works on old Sony with Android 4.1.1. and on a Noname-China Tablet with Android 4.4.2.
    The Windows application has with 64-bit and 32-bit problems finding over Wifi to address Only rarely works.
    I think, this is due to the Windows 8.1 versions. Maybe we can extend the configuration in Windows, so you can set the connection using the IP address to the router.?.
    A big thank you for your great Job, for my Nikon D5100!

    1. I’m also on Win 8.1 x64 and here network discovery works. CHeck if on your router broadcast address is set (should be by default)

  40. On.my huawei honor 3c this app is not working it said a fatal error occured app is not star 🙁

  41. Please tell.me.about the solution how can I start this app on my huawei honor 3c???

  42. Hi Zoltan,

    My TP-Link MR3040 is not connecting to my Nikon D800 with iPhone or iPad, please advice.


        1. Here:
          If you have the original TP-Link firmware on you need to update. The latest firmware is always here: http://dslrdashboard.info/downloads/
          Instruction on how to flash the OpenWrt firmware is here: http://dslrdashboard.info/tp-link-mr3040-openwrt-flash/
          OpenWrt firmware instructions is here: http://dslrdashboard.info/tp-link-mr3040-firmware-upgrade/

          Best you connect your MR3040 to your desktop PC with a network cable and check it’s web interface.
          Original TP-Link firmware web interface is at
          OpenWrt firmware web interface is at

  43. Hi Zoltan

    Thanks for Version 2.7 – was happy to see, that with this Version can now Change camera Settings i.e. Film-Speed, exposure-time, apperture, etc. However, only in Manual Mode and even worse, after one shot the System is either hung-up or the program just Closes. PS: I’m using your app with my iPad and with a Canon EOS 60D.
    Best regards

  44. Hey, this would be great to use on my pentax K50 (supports PTP) Any future plans for such? It force closes on Android Phone (Galaxy Alpha)

      1. thanks for your reply, what is it you’d need exactly and I could do some searching and see what I can aquire…

  45. Ciao
    aggiornata da 0.2.6 a 0.2.7 su iPad crash continuo , non parte

  46. Hi Zoltan, I’m a early adopter of your app since shooting with Nikon cameras for my videography work.
    Now I’m trying to use this latest version of qDslrDashboard with my Sony A6000 camera on Android and on Mac, and I have a few questions:

    – Via Wifi, I can get LV to work although its not near real-time some times, but it works.
    I don’t see the video camera button but on my mac I do see the button for “LV REC”, how exactly does this function work and why the files stored on disk are unreadable and always 414 bytes of size?

    – It would be great to just have the normal camera button (for movie recording) since I know this camera does has great support for video, when do you think that can be added?

    – Why can’t I find this same camera (Sony A6000) when connected to usb?
    I think if I use the usb connection to an android phone, the image feed would be much faster and much more accurate.

    Hope to hear from you soon.
    Best Regards!

  47. Dear Zoltan

    Latest version not working on iOS 5.1.1 (black screen). App would not start.

      1. Yes, it worked. But I recently purchased a new camera, Nikon D5500, and that is why I upgraded to latest revision.

          1. Hi

            Any progress yet regarding the IOS 5.1.1 problem?


  48. Hello!
    Since the Generic PTP class was added, is there a possibility that qDslrDashboard might be possible to use with newer wifi enabled Nikon Coolpix compact cameras, like the P610? Or will it definitely not work?

      1. Thank you very much for the clarification, Zoltan!
        A final question just to exhaust the issue.
        Would you need physical access to the camera yourself to examine what PTP properties/commands it supports?
        Or could another person (without special camera hacking skills) perform a set of instructions/tests to extract the necessary data from the camera?
        E.g. something like what is described here:
        (“To report a not yet supported camera…”)
        Any way, thank you for your great technical contributions to the world of photography!

        1. That would give me just some info about what PTP commands/properties the camera support.
          To get it working I would need a camera for testing to understand what those commands/properties change on camera.

    1. Please check the manual available from downloads.
      Capture in RAW+JPG then the JPG will be downloaded and displayed if image review is enabled.

  49. Ciao
    Versione 0.2.7 non funziona crash immediato con iOS 5.1.1
    Versioni precedenti 0.2.5 0.2.6 OK

  50. Hi Zoltan
    Any hint for why program is either freezing (hung up/blocked) or closing down after capture? This happens in all modes. App Version 2.7, Camera Canon 60D, iPad. Thanks for assist!

  51. Hi Zoltan,
    Was using a Nikon D810 in the studio and had liveview on and the flash would not go (fire) I turned liveview off and the flash triggers worked using Qdslrdashboard to take the focus and take the picture …..Question how do I get this to work with liveview on in Qdslrdashboard ?

      1. It was external flashes with the trigger on the hot shoe
        With studio flashes !
        If I use LV it won’t flash !

        Turn LV off and the studio flashes work ?
        Then images come to ipad and display fine .


          1. What are the flash settings on the camera? What exposure mode do you use? Do you use Nikon CLS ?
            qDD does not prevent the flash from firing, it is one of the camera settings.
            Can you maybe open a topic in the firmware.

  52. Why is my submitted question keeps on being taken out? I would like to know if this apps can run on old iPAD (no camera version) and iOS 5.X. If official answer is no I then buy an android tablet. I believe this is a legitimate question.

      1. sorrrrrrry…….and thank you ….I am not a computer guy…..so not too good in forum type thing…. truly sorry and thanks for answering…. don’t know why my question somehow just disappeared after I post it………so these are two places…..here and the forum….I think…..

  53. Hi, Using qDSLRDashoard V 2.7 arm, USB-connection
    Works fine on a Asus Nexus 7, ANdroid 5
    Don’t get any connection with an LG D620 (G2 mini). Application loads and then hangs … when hitting USB-button.
    LG D620 runs with Android 4.4.2, hardware setup for USB is set to PTP (MTP is also available, but didn’t work neither)

  54. When are you going to fix the server problem with this version? I am now stuck with this on both my devices and cant shoot anything

  55. Hi Zoltan,

    would you pleeeease add onion skinning to your app. There is still not a single stop-motion app for android available that let’s the user control a dslr. It would be just great if you made it possible to compare/toggle bewteen live view and an image stored. It would be necessary to see the image and source overlayed with 50/50 transparency and also be able to change the transparency to 100% so that one can toggle between live view and stored picture. Thank you!

  56. Using 0.2.7 on IPad Air with Canon EOS 5dmkII

    After a couple of captures the App Display show
    “capture in progress ” and I have to Start the App again to take more Pictures.

    Is there any Solution Fot this problem.


  57. Using mr-3040 II runing Firmware Version

    OpenWrt Attitude Adjustment 12.09.1 / LuCI 0.11 Branch (0.11+svn9951)

  58. 0.2.7 on ipad2 (ios8.1)immediately crashes after start a while

    Thanks and regards, Aaron

  59. This version on OSX Yosemite (or latest version) is crashing after 50-60 pictures. After the crash I have to force quit and it will crash several times before I’m able to get a string of 50-60 pictures.

    Canon 60D with magic lantern connected via usb2.0. Mac book pro i5 8gb ram.

    Allowed for over 2 seconds of transfer time between the shots to transfer the JPEG and allow the buffer to clear. The last version (2.6?) was more stable. If there isn’t a quick fix for this issue, is there a way I can download a previous version until the issue is addressed?

  60. Hi Zoltan
    Got a bit confused…. Found no simple answer to the only question I have: Is Live View supported with Nikon D7200 with it’s internal WLAN adapter?
    I can connect and shoot pictures, but got only a black Screen when switching to Live View. I have IOS 8.3 in place and your latest Version from the AppStore.
    Tnx for your answer.
    Regards, Stefan

    1. Nikon didn’t release yet the documentation for D7200. I’m waiting for it to add full support for D7200 including live view

  61. Hi!
    DSLR camera maker and model: Nikon 5100
    Platform used: Android 4.4.2
    For Android device: LG G PAD 8,3
    Description of the error and how to reproduce it
    I have the last version that is on Google Play now.

    The app works BUT only few seconds. In live view, after 3 o 4 seconds, the image always freezes.

    Help please!!!

    1. I already answered on 2 different places that I don’t maintain the old Android only DslrDashboard and that you should use the new cross platform qDslrDashboard available from this site.

  62. Hi Zoltan
    I brought new phone
    I get black screen only
    My is ASUS ZenFone 5
    Android 4.4.2

    My old phone PadFone2 everything well

  63. Hi
    Will dslr dashboard work with the d7200? Will it be stable??

  64. Hi
    I can not connect my camera with usb cable on my computer with QDSLR DASHBOARD please tell me the solution how can I connect my camera with usb tethered cable on my PC …..

    1. I believe you should be a bit more specific on which OS you are using, which camera and so on, otherwise Zoltan won’t be able to help you

  65. it can connect it wireless only but can’nt with usb tethered cable??

  66. Aggiornamento a 0.2.7 non funziona con iPad e iOS 5.1.1
    Versione 0.2.6 tutto OK

  67. Raspberry Pi:
    nothing! Didn’t start at all!

    pi@raspberrypi ~/qDslrDashboard $ ./qDslrDashboard.sh
    pi@raspberrypi ~/qDslrDashboard $

    Also tried as sudo – same effect.

  68. FYI: had difficulty getting iPad wifi-d to mr3040 to canon T4i….then I changed usb cable from eBay one to original canon cable….everything started working.

    Have no trouble with eBay usb cable when tethering to laptop, whether using some app or directly. But when connected to router, it fails


  69. Are you able to test qDD on a HTC phone (preferebly an m7)? Performance is pretty terrible, though everything works.

  70. Hi Zoltan,

    I have been troubleshooting with the latest version V0.2.7 on OSX Yosemite version 10.10.3. I had just recently updated the operating system and I’m experiencing the same issue I had on the previous version of the operating system. I have my Canon 60D attached to my MacBook Pro via USB and it only detects the camera via one of the USB ports. The other doesn’t operate in QDSLR. The other issue is crashing. I’ve attempted to use ML’s interval timer, and I’ve attempted to use QDSLR timer. I’ve used it in the Holly Grail Mode, and in the standard mode. I’ve used different intervals 5s, 10s, 15s, 25s and all have resulted in a crash. Initially I was able to get 50 or so frames shot and every crash after that would get me as far as 1 to 20 shots. Now I get as far as 2 or 3 and it continues to crash. Any idea on fixes?

    Love your product!


  71. v0.2.7 is not closing if I turn my mobile screen off and turn it on after some time, qDB will crash on my Nexus 5 with Lollipop 5.1 and Samsung Galaxy Tab S with 4.4. I used a canon 5d mark II.

    qDB is not ¡stable under several scenarios like this one. I have to have my mobile screen on all the time for fear of a qDB crash.

    I connected my Canon 5D Mark II with tp link WiFi using Samsung Galaxy Tab S with 4.4. Connection happens, when I press LRTimelapse button qDB will crash and close.

    I sent you 2 days by email the logs for the first problem where qDB will crash if I switch on my mobile screen after being off for some time.

    qDB is a GREAT software but it’s not stable under a few scenarios like these, so when you are shooting a good timelapse, it will almost always crash for some reason 🙁 Murphy also has laws for qDB and photography.


  72. Hi Zoltan,
    many thanks for the app. Some problems with A6000 and the LRTimelapse function
    My config: A6000, Asus Android 5.0, MacOs Yosemite, USB + WiFi.
    At first i’ve tried out the config with my Android and Wifi, works but the picture preview transfer is slow and the response from camera to the tablet comes late, not in sync.
    I thought it’s a good idea to test it with USB-connection. The access from camera to tablet or Mac is O.K. but no reaction on camera or any function in app. LRTimelapse says “Warning, Camera is not in M mode – Image format is not in RAW+jpeg”. Any ideas?

  73. Hi,

    In the fist place I like you program a lot. I’m here due to the advice of Gunther Wegner.
    This is the first time I’m using DslrDashboard V.0.27 on my macbook air and connect to my Nikon D700 via USB. The program seems to be working fine but when I’m using the Auto Holy Grail option its stuck in that section of the program. Even when I’m shutting down and starting it again it still opens in the lrtimelapse section. And I can’t get it out of there 🙁

    Any advice?


    1. I have the same problem sometimes and there is no way to go back to the main screen when pressing on the X close button on lrtimelapse

  74. Hello,

    About my previous post.
    I have solved it. I know now what I did wrong.
    Sorry about this.

    Kind Regards,


  75. Hi,
    with my Win 8.1 tablet I have a problem with the D810 connecting with the USB port. The camera is found but the communication is very slow. It takes a long time (about 2 minutes) until it starts and any change is slow again. With my D800 it works fast. If a USB hub is between the D810 and the OTG port then there is no slow down.
    With a notebook there is also no problem with a direct connection.
    Any ideas?

  76. Purchased the iOS version and tested with my Nikon Df and WU-1a and my ipad air with iOS updated to the latest version.
    The software is not stable and the crashes are continuos, especially using LV. I have ordered a TP-Link mr3040 to have the dashboard work on my D810 as well, please work hard with your bug fixing activity, the program when will be reliable will be a great tool.

  77. Hi .

    I use a Nikon D3300 with qdslrdashboard android app .

    thanks for your great app . i use it mostly for HDR capture . but there’s an annoying Delay when i shoot @ different exposures (bracketing) . the camera cant record @ 5fps so why i cant use that speed for HDR bracketing ? isn’t there anyway to increase capturing delay between two shots when bracketing for HDR ?


    1. Hello there, I too own a D3300 and I am wondering, are you able to record video while using the app? Is it possible? New to the app, was trying to use dslr dashboard app from the android market but I wasn’t able to get it to work, all I got was a black screen. Found this through a forum, but I am not liking the interface of the QDSLRDASHBAORD much rather the interface of the android app from the market, seems a lot more options. Well hop, you can answer my original question. Thanks.

  78. Hallo Zoltan,

    my system is an nexus 7 – canon 70d

    Lrtimelapse crashed a lot oft times.
    It was working, but after 71, 206, 350 frames in holy grail mode it crashed. After that i didnt count it.
    I tried wifi and USB. I think it is a little more stabile in USB but no big difference.

    I also had the Problem with the black screen in lrt-mode

    One big Problem for me is, that i can not use an external intervalometer. The camera dont react to some external device

    But the major Problem are the crashes. I can not use it right now i only working Manuel.

    Hope you can fix that.


  79. I faced many problems to let it work with my Nikon Df and the WU1B on iOS but I was suspecting something wrong with WU1 or mine WU1.
    Just arrived the TP 3040 and after firmware flash I tried to test with my Df and my D810, I did just first preliminary test but now let me say that is working very smoothly with both cameras.
    Didn’t test the advanced function but considering how the system is now responding I am ultra happy, keep on working is a great app

  80. Used it to grab the photos from my d750 to my laptop for printing to a printer during an event. Noticed that it doesn’t grab the photo from the camera when the app is not active. would be great if you can make it so that it will grab it whenever a photo is taken whether the app is active or in the background. that way I won’t have to worry about the photos not being transferred to the computer when my assistant sends photos to the printing queue.

  81. Some feedback from me:

    Acer A500 / Android 4.3

    V0.2.6: works
    V0.2.7: not starting
    V0.2.7.4: starting, but stucks in image viewer
    V0.2.7.7: starting, but stucks in image viewer


  82. Hallo,

    I have a problem with qdslrdashboard.

    Somtimes the recognition stacks with my D700. But the biggest issue what i have, i cant shoot in LV. Whats happend in LV is activated and i press the shutter button is, the mirror flips down, the software tells me pictures is taken now, but the shutter doesnt work. Means no pictures will be taken. When LV is turned off it works perfectly. Is it possible to fix this issue. Many thank from Germany.

          1. Hello,

            it seems, the debug tool is is for x86 Windows. But i have a x64 Win7. The Debug tool doesnt start.

            It apears a message cant start correctly. Close now.

            Best regards


  83. Just installed the app on my phone runnig Android 5.1. Tried on two different tabs and was having problems. Using with D3300.

    Few issues I have noticed.
    1) when using live view throuh the app every movement is jittery , not smooth at all. When playing back a recording the jittery movement is present.

    2) no audio playback.is this a known issue?

    3) no way to check exposure while on live view through the app.

    I would like to use this with my phone as an external monitor. Are these issues comon or is it because I am using a low end dslr?
    Any suggestions? If so please di reply or better yet contact me at antoniodinis78@gmail.com. Thanks.

  84. Hello,

    Attempting to connect to my Canon EOS 60D using qdslrdashboard but having difficulty. Firmware upgrade instructions followed. When I run the app on my Iphone 5 it displays the initial screen and I select the Canon option. The app does the search but does not take me to camera controls. Verified that camera is ‘awake’ and Live View on. Any ideas? Thanks!

    1. Did you pair your iOS device wireless with the 60D wireless? You should not enable live view on camera before connecting to it.

      1. Yes, I’m using TP-Link router and have it connected to the camera via USB. I’ve joined the WI-FI to the IOS. I retried the connection with ‘Live View’ function off and saw the same results – no activity. Is there another step I must do that I’m missing?

          1. I don’t see a ‘Network’ button on the TP-LINK. I have a mode button with three selections – 3g/4g, WISP Client Router and Travel Router. I’ve tried all three of these modes with no success.

  85. When I select the Connection button it displays ‘Search for DDServer’. When I do the long press I get the dialog box for IP Address. The default IP Address is – the TP-Link address. I press connect it says ‘Getting DSLR device list from DDServer at I select the Canon button and no change in response.

    1. Is the TP-Link flashed with OpenWrt and ddserver? Is the camera connected with the USB cable to TP-Link full size USB port and turned on? As I already said you must use the ‘Network’ button for the TP-Link connection.

  86. Yes, when I open the browser and connect to the TP-LINK, I verify the current firmware and it says ‘OpenWrt’. Camera is on and operational. I’m using the same USB cable that I use to download images to my computer.

  87. Sorry
    Scaricato versione 0.2.8 per iPad con iOS 5.1.1 non e’ cambiato nulla , non si avvia crash immediato come 0.2.7
    Versione 0.2.6 tutto OK
    Possibile downgrade a 0.2.6 per iPad e iOS 5.1.1

    1. How do I downgrade? Also, I’m running on an Iphone and not an Ipad. Will that be a problem?

  88. trying to connect my 60d to nexus 7 through otg. qdslrdashboar is not detecting the camera. any help to dove the problem will be highly appreciated. thnx in advance.

  89. Is there anything else I should try? Do you have verification that this works with a Canon OS 60D?

      1. I did not. I’ll follow your upgrade steps and let you know. Thanks!

        1. Followed every step outlined but still no change – app does not connect to the camera. Verified the camera connection, set, connected to the TP-Link through settings but still no change. What should I try next? I was not able to connect to the router as the URL has changed. If you can give me the new address I’ll connect and search for the ddserver.

          1. Do you see now the ddserver package in OpenWrt web interface under System->Software ?
            Btw using the forum would be better.

  90. Hi
    I updated to version 0.2.8 with iPad and iOS 5.1.1, but does not start instant crash. The same as 0.2.7 does not change anything. Not used
    The 0.2.6 was OK.
    You can make a downgrade to 0.2.6?

    1. Unfortunately I know about this as was reported already.
      Yesterday all day I was trying to find out what is the problem and seams I found it. Will do some more test today and if everything goes well will push q quick fix release.

        1. Reloaded firmware again. All is working. Product works great! Thanks for your help.

  91. Hello all, i dont want to be a pest, i have not gotten any replies or suggestions to my original issue (please see bellow)

    Just looking for confirmation if this app will work with my equipment. Thanks and i am sorry for being a pest.

    {{{{{{{Antonio Dinis
    MAY 7, 2015 AT 21:24
    Just installed the app on my phone runnig Android 5.1. Tried on two different tabs and was having problems. Using with D3300.

    Few issues I have noticed.
    1) when using live view throuh the app every movement is jittery , not smooth at all. When playing back a recording the jittery movement is present.

    2) no audio playback.is this a known issue?

    3) no way to check exposure while on live view through the app.

    I would like to use this with my phone as an external monitor. Are these issues comon or is it because I am using a low end dslr?
    Any suggestions? If so please di reply or better yet contact me at antoniodinis78@gmail.com. Thanks. }}}}}}}

    1. The jittery (around 4fps) liveview is definitely a factor on my my HTC One m7 to the point where the app is barely usable for liveview. Nothing I’ve tried makes things any better so I suspect you may be waiting along with me for an eventual fix (hopefully)

  92. 0.2.8
    Nikon D610 / WU-1b
    iphone6 plus / iOS8.3
    LV mode was too lag to use (often hang for 10s or above, and drop the wifi link)

    p.s. Similar problem happened on Nikon’s own APP WMU, too! I turned to your paid APP for hope, but still …

  93. Latest version not working on iOS 5.1.1 (black screen). App would not start.

  94. hi zoltan
    the app is working greatly, there’s just one problem that really bugs me
    i have a nikon d810 and a lenovo s6000 tablet, every time i take a photo it takes it then says capture in progress and it never goes away so i have to shut the app and start it over again, any solution for this plz?

  95. hi

    question: with a Nikon D750, your software, and an ipad air, I would like to be able to have the ability to shoot through the optical viewfinder of the camera and have the live image sent to the ipad, so a client can see what I’m shooting. Currently, it seems that if I use DslrDashboard, the mirror in the D750 goes up, and the optical viewfinder is black, while the ipad has the image. Is there a work around for this so I can shoot from the camera and have someone else monitor what I am shooting using the ipad as I shoot? I know you can download a series of images to review, but can we show what is being shot as it occurs? Thanks, Ted

Comments are closed.