qDslrDashboard for iOS update

Posted a new version (V0.2.2) for review with following fixes:

  • fix for Canon wireless not discovered
  • fix for Sony wireless not discovered
  • fix for video recording not working with Nikon D7000
  • fix for ‘Slowest shutter’ change not working in LRT
  • fix for ISO change not working after reaching ‘Slowest shutter speed’ in LRT
  • fix for black image on iOS 8
  • iOS8 stability fixes

177 thoughts on “qDslrDashboard for iOS update”

  1. Great App, Zoltan!

    … but there is no update available in the Appstore in Austria…!?!

      1. Hi Zoltan, love the app, great work! I’m using it with my MBP, iPhone and iPad. I’m going on assignment next week to outback Australia and am planning on shooting some time lapse, using my iPad. I am really hoping the update is released by then! It’s the only reason I bought an iPad haha. Heath.

        1. I see that it possible ti use Qdslrdasboard om a Macbook pro but how, where can I fnd the app?

          I use it now on my Ipad mini but on the macbook it nicer.

  2. I thougt it will be something like that…. good to know 🙂

    1. Unfortunately the D4 and the WT5 are out of my budget and there is no documentation about the protocol Nikon use. I presume Nikon uses the PTP/IP protocol so theoretically it should work (maybe some small modification would be needed) as the PTP/IP is already implemented and used with the WU-1a/1b and D5300. You can try with the ‘Nikon wireless’ button. If you long press it you can enter the IP address of the WT5. For the WU-1a/1b/D5300 the IP Nikon uses is

  3. greetings!
    the app crashed just after the download from the appstore on a mini retina on ios8. 🙁
    what can i do?
    best regards.

  4. sorry about the confusion.
    after connecting to the same network as the camera, the app started.
    … a hint while booting would be helpfull, but now it works.

  5. At the moment it seems that not all functions with the new Nikon D750 with Wlan support are working. For example Live View!

    1. There is no SDK yet for the D750. You could help me if you could give me the D750 USB productId. You can check that in Windows device manager. VendorId should be 0x04b0 and the productId is probably 0x0437 or higher.

      1. I will geht my own d750 Byte end of october. If the Info,is still missing i will send you a short Message!

      2. Ah yes. The D750… live view isn’t working, and I can’t seem to get images to view (so LR function isn’t working). BUT, as I have one in my hot little hands, I am looking for the Vendor ID… here somewhere… no… poking over here… maybe… no… humm….
        Location ID: Port_#0001.Hub_#0003
        Hardware Ids: USB\VID_04B0&PID_0437&REV_0100
        Device Instance Path: USB\VID_04B0&PID_0437000003006408

        …any of those helpful?

        THANK YOU!!!!!


        1. I did added code that should enable LV with D750. On what platform do you use it? What you mean with can get images to view, the LRT module uses JPG so that does not depend on camera model.

      3. Hello I have the d750 and the application does not work on the iOS device ( while it works quite good, except for video, on android)
        Please contact me if you need any support/test.
        My email is diego.petracca@gmail.com

      4. There is a SDK yet for the D750. I can use the D750 in connection with the new Nikon Camera Control Pro 2.

  6. It looks like the average approval time for new apps is up to 9 days as of this week. That means that updates should take slightly less time. Given that you submitted it a day or so ago it should be done by Monday hopefully. Planning on taking my camera and DSLRDashboard with me to the mountains with my telescope this weekend!! http://appreviewtimes.com/

    1. the app is non-functioning since I got the iPhone 6 and iOS 8.

        1. Sweet man, thanks for all your hard work! I look forward to the update.

    2. HI Victor.
      2/3 days would be ok – but 9 days….
      I can’t unterstand why an app, which has allready been sold in the Appstore has to be approved again.

      beside: I updated my ipad “by accident” and need that fix desperatly (I do not have the time to downgrade…. don’t even know if it’s still possible). I know – it’s now up to Apple. So Guys in Cupertino – hurry up!!!

      1. Hey, if you really do need it that urgently you definatley can downgrade your iPad. Here are the instructions on how to do just that: http://lifehacker.com/downgrade-from-ios-8-to-ios-7-1-2-while-you-still-can-1637650142. Hope that helps.

        It depends, right now there will be an influx of devs updating there apps to make them iOS 8 compliant. More so than say there would be a month from now. I just got the 6 but I may have to borrow my sisters old iPad to use the app for this weekend.

  7. Hallo Zoltan,
    I’ve got the problem, that I can’t change the focus point on the display of my IPad.
    My equipment: Nikon D300, IPad Air, TP-Link-Router, qdslrdashboard
    The connection between IPad and D300 is working well. I can see the Liveview-Picture from the camera on my IPad. But unfortunately the Finger Tab Focus does’nt work on my IPad.
    Are there any hints from you? Maybe I have to make some settings on the Camera or software.
    Thank you and best regards

      1. Nice, Zoltan! Thank you for the reply.
        It’s great to hear that yor are busy with my
        Have a nice sunday.

          1. On 5DM2 it is a different problem. I’m trying with a help of a user to resolve this issue (unfortunately Canon does not provide documentation for developers)

      1. Hi Zoltan,
        I’ve tried the ‘tripod shooting mode’ on my D300! And… it generally works! But… when i choose a focus point with my finger, which is far away from the middle of the motive, and then activate the release button in the software, i get a photo, which is focussed in the middle and not on the defined focus point before.
        Do you have an idea?


        1. Was the AF button red before you pressed the capture button? If yes then turn it off by long pressing the AF button (it means the camera will do auto focus before capture). I will check the D300 documentation.

          1. The AF button was not red! The finger tab focus works fine but after capture the photo is not focussed on the point I wanted.

        2. I have exactly the same problem. The application isn’t updating the cameras focus point.
          I can focus in live view and it looks fine on my Ipad but when I trigger the camera it uses whatever focus point was previously set at the camera.

          1. P.S
            My camera is a Nikon D300 and I am running the IOS app on my Ipad.

          2. I had the exact issue on D700.
            I’ve solved by setting the Focus-mode selector on the camera body to C (continuous)

          3. I have to correct myself,
            It is important to setting the Focus-mode selector on the camera body to C (continuous); (that way the camera will not try to get focus before shooting)
            But also, the only reliable way to make the autofocus to work in Live View on D700/300 (on every platform i tested mac, pc Iphone Ipad) is to choose the focus point, then press the af button on the left side area, and when the focus was gotten, turn off Live View and only then press the shoot button, with the live view turned off.
            This way i haven’t lose a shoot, it is really a little bit annoying, but reliable waiting the next update.
            I’m really sorry for my english

  8. Hi Zoltan,
    Is your iOS app tested with a nikon d800e?
    Thank you

  9. Hy Zoltán,

    Since i Update to iOS 8 i didn’t se any Images. The Download Message is shown, but the Image isn’t visible, and is not found in the ipad-Storage. My Equipment: ipad-air, nikon d800, tp-Link.
    Any Idears?
    The LV is shown.
    Regards Arnd

    1. Yes I’m aware of this problem and already posted a new version but it is still in Apples review process. 🙁
      Probably they are busy with the problems regarding iOS 8.

  10. I just purchased and have iOS 8.02. I loaded my 3040 with latest version. When I can get the app to load and I am connected to the DSLRController. Nothing happens. Am I missing something? Thanks.

      1. That is odd, I was using DSLRController before. Didn’t even realize the difference until last night. Bought your app for iOS. I DID flash my 3040 with your .bin file and still comes up on my network as that. What is your standard SSIP? Thanks so much!

        1. The default AP is DDServerAP. If you flash over the ddserver OpenWrt image and checked the ‘keep seetings’ options then probably it will preserve the old AP name. Check under System->Software that the ddserver package is installed, should be V0.2-13

  11. Just a note-

    App crashes for me now a split second after startup

  12. Hi, purchased the iso app, configured the Tplink router to my D800. No that works fine, am able to trigger the camera via my ipad. Trying to do a timelapse, but when i click auto holy grail nothing happens? Isnt this supposed to start the capture sequence?

    1. The ‘Auto Holy Grail’ button will not start an interval timer. You can use the built in interval timer (a button in the bottom of the LRTimelapse screen) or use an external interval timer.

      1. Ah nice! Found it thanks!

        Then one other issue, is that it has been giving me big problem connecting as of late.

        Everything is set, but when I click the Nikon tab, nothing happens. Every now and again by luck it seems to work. Using iOS7 still. Will this be sorted in the latest patch?


  13. Hi Zoltan,

    create Programm! I test it with my Nikon D70s and it works fine. I use yourProgramm with Win7 64Bit in Version 0.2.2.

    Only the Bulb Shutter doesn`t work. I can set it to bulb but if I set the time and start the capture nothing….

    I have also install the App on my iPad Air with IOS 8.0. I will wait for the App update to 0.2.2 🙂 to check the upload for the Images.

    Thanks you for the create App.


    1. The BULB capture is only available on newer Nikon models (D5200, D5300, D7100, D800, D800e, D810, D600, D610, D720, D4, D4s, DF)

  14. I’m so happy about this app, Zoltan! Especially that you now developed it for iOS! Unfortunately I cannot connect my Canon EOS 5DIII to the TP-Link TL-MR3040 V2.x WLAN-Router (Edition with installed DslrDashboard for NIKON & CANON EOS). There’s no connection showed on the display of my iPad and iPhone. What do I do wrong? I would be glad if you could help me?! Thank you!

    1. Connect your iOS wireless with the MR3040 and long press the ‘Network’ button (the first one from left). And in the IP dialog enter ‘

    2. It doesn’t work. iPhone and iPad recognize the WLAN from MR3040 in the settings and they connect to it. When I enter the IP-address in the app as you told me and I press “connect” nothing happens. When I restart the app always the IP appears. My entered one hasn’t been saved. So what else can I do?

      1. Hi Zoltán. I updated the App…now my further problems are solved…Thank you!

  15. Got a D750 for the next two weeks.
    I am using Android 4.3 on a Samsung Note 2.
    I have dslrdashboard 0.30.33 on the phone and can get the D750 to send the liveview, but only for 1s, then the app stopps.
    If you need any info, i like to provide if possible.
    I really like to see one of your apps works with the D750 over wifi.
    Best regards

  16. Lässt sich schon abschätzen wann das Update im AppStore auftauchen wird?

  17. I can’t connect my Canon EOS 5DII to the TP-Link 3040 V1. I flashed the 3040 with the firmware from this website and checked the DDserver is the newest version.
    I lanched the qdslrdashboard with my ipad (iOS 7) and my ipad mini (iOS 8), I can link the 3040 but the qdslrdashboard has no connection ti the camera so there was no image form camera showed. I click on the left side network button and input the IP but still don’t work. Please help!
    (PS: I used a USB cable to connect 5DII to my notebook and it worked fine.)

    1. I replaced the cable with the one came with 5DII , everything works fine now.

  18. … still no update available Form iOS After 11 days… whats’ up?

  19. I am using a D750. Liveview is not working on OSX App (USB and Wifi). Anyone knows if it’s working with iOS? Would be cool…

    1. Soon I will release a new version that will have a working LV for D750.
      I hope that Apple approve the new V0.2.2 for iOS soon (it is no in review process)

      1. Hi Zoltan,
        I put in a support ticket with a request for how much longer it would take for your update to be approved. I may have helped because we both got emails. Anyway the update is approved and posted!!

      2. Opps, now it’s not! Must have been wishful thinking and seeing things. It said October 4, now back to Sept 9.

  20. Your special version for the D750 works great.
    Its so nice to have focus peaking 🙂

  21. I have an icon for film, but it is not working.
    No film function yet ?

  22. Just downloaded the update to the iPad 3 and iPhone 4s
    Will let you know how it goes later today !
    Thank you for the fix.

  23. That didn’t take me long to break it !
    I have a canon 5d mark 2 Tplink with 2.13 .
    Dowloaded the IOS update oh running 8.02 .
    Have had lockups where I had to shut the ipad off and start again. Blow outs after touching the pictures button the list goes on and on ……..share don’t share on both iPhone and iPad at the same time like the CamRanger does !
    Before the next update can you grill the app like I just Did please
    I gave it a thrashing and I won the App still crashes .

    I don’t have the time to waste So please fix it and test before uploading it to Apple as not just me are throwing bricks at it to see if it breaks .

    Can you save the images to the iPad like on the Android ?

    If a few other people can thrash it to see what else could make it blow out as well.

    All this should have been done before realising the update !!!
    Just venting my frustration after waiting 2 weeks to fix it ,
    it is still broken !

    1. Please can you make a forum post describing the problems you encountered?
      Sorry that you needed to wait 2 weeks I can’t do anything against Apple review process.
      You can transfer the images to iOS but every application is sandboxed so the files are only visible inside the application, or when connected to OSX/Windows.

      1. Hi first thing a few times I have click on the app since it has been updated it has crashed !Blew out ….

        Once I did get it to work I clicked on the picture tab it
        And it blew out the app .
        There has been other thing that made it crash as well different things shining the app I clicked on made it crash you would find this out your self if you thrashed the crap out of it first.

        So you being the maker can you try yourself to break the app that you made and you maintain I broke it in a few mins of using it .

        Also sandbox ?

        With CamRanger you can save the pictures to your library on the iPad or iphone ! sandbox ?

        Before the next realease can you try and break the app so you can then know what to fix….. Just thrash the living daylights out of it let it break so you can fix it and make it more stable .
        If the app worked and saved images and share in realtime like the CamRanger I would pay $50 for your app.

  24. Working ok for me using Nikon d800e. ipad is a bit slow rendering the raw files (36mb) but ok with jpg.

    Is it possible to get the app to only dowload the jpg and from the SD card leaving the raw file untouched on the CF card? That would be really useful as I only need to review a basic jpg, nit the full raw file. I will post in the forum 🙂

    Thanks again for a really useful app.

    1. Yes just set camera to shoot raw and jpeg basic. Then just delete jpegs when editing

  25. Such a Great product. I have one question/request…
    (On the OS X version) I can’t see how to reset the coordinates from which zooming in will happen after you click on an alternate focus/zoom point. What would be very useful for me is a way to zoom into the very centre of the frame (on my D800) so that I can locate a star at the exact centre of the sensor frame for telescope polar alignment. Alternately a cross hair or set of grid lines that always showed the grid (and centre) with respect to the original sensor position as you zoom in would be great!

  26. Things working much better now on the D750, except I can’t get live view to work.

    Other than that, thank you for the update!

  27. Already update QDSLRDASHBOARD but cannot detect D90 (via USB cable). Can import photos but no live view or any functions..

  28. I’m new here. Is there any known way to connect iOS devices via USB (as opposed to TP-Link?) to Canon cameras? Just curious.

    Thank you for all your hard work. I’ll be buying the app soon!

  29. Thanks great app. Noticed the Slowest shutter not working with ISO but all good now after update.

    One quick question:

    I did a late evening to night shoot tonight. Now the histogram was very much the left (blacks) most of the shoot. The EV reading was around -2 to -3. Is there a way to exp compensate manually?

    Just feel that this shoot would have been better with a stop or so longer shutter as its pretty dark now. I set the slowest shutter to 10sec and max ISO to 400, yet it didn’t go past 5sec at 100 ISO.


  30. Hi Zoltan,
    I only have a Nikon D3100 that doesn’t offer wireless connectivity. Is there anyway I could connect the camera to my iPad using a cable?
    (The mac Version never worked with my camera -the screen stayed black- so I’m hoping the app will somehow for me)
    Thanks for the great work! 🙂

    1. Sorry but the D3100 is a budget model with limited set of PTP commands so it will not work. The next version for OSX (and other platform) will improve this when connected with USB.

  31. I am new to this forum. With great interest, I have flashed the new TP-Link and also downloaded your app from Apple today for my iPad($9.99) paid. Unfortunately my ipad cannot connect.. There is one Nikon icon in the dashboard when pressed indicates trying to connect to Nikon WU-1A/1b/D5300 then indicates failed.
    Can you please help what to do next?

  32. Hi , i see the last update you say about nikon d7000 , now this app can use with nikon d7000 on ios via usb cable ?

      1. The Nikon D3x00 are budget models with limited set of PTP commands/properties and they don’t have the command for starting/stoping movie recording. The only solution would be to upgrade to a higher model (D5100 or higher)

  33. Hi Zoltan,

    Any idea if DslrDashboard IOS will be compatible with Sony soon? I have NEX 7 and would love to be able to pair it up with your app.

    Many thanx

    1. The latest iOS version already has the Sony code. For now it is very basic functionality, take picture (no preview), change shutter/aperture/iso/exp.corr/wb, live view. No Custom bracketing, focus stacking and LRTimelapse (I will see to add LRTimelapse in future for Sony but needs a lot of work). I only have a Nex 6 for testing and it is lacking a lot of functionality that other models should have. You can test with the Windows/Linux/OSX version if it suits you.

  34. Hi, i have an ipad mini (1), a canon 5d mk ii, an apple lightning to usb camera adapter, a usb cable and i buy your app from the app store. My problem is that the ipad cant find the camera and so i cant use these app.
    can you tell me what´s the problem on these or some tipps for me?
    If i tip the button “usb” (left above corner) on the ipad the ipad “Searching for DDServer” but that´s all. No connecting to the camera is possible.

    Your programm runs on the mac perfectly 🙂

    1. Hey Rico,
      this is an issue with Apple devices.
      They do not provide a usable USB-interface for such applications.
      Zoltan already explained that above (see his comments from October 7th)

    2. Zoltan?
      I pay for this app. Please help me to run it on the iPad.

      1. qDslrDashboard for iOS does not support USB connection as there is no USB port. The CCK is not open for developers so it can’t be used. The first button on iOS from left is the ‘Network’ button, there is no ‘USB’ button.

  35. hello,

    i bought the app on iPad 1 running iOS 5.1.1 and it keeps crashing every time i try to open the app. any ideas?

    thank you.

      1. any update for using the app on iPad 1 running iOS 5.1.1???

  36. Hi, I’ve got a brand-new Nikon D750 today and tried to connect qdslrdashboard with my iPhone (iPad too) through wifi, the app recognized my D750, but the LV screen is just black. Doesn’t work LV with D750 ?
    Or I just need some setup on the app?
    And do you support D750 movie LV, too?

  37. Hey Zoltan,
    thanks for providing a working iOS version finally!
    I have a D800e with TP-Link and iPhone 5s / iPad 3 (both still with iOS 7). Everything is working fine.

    I have just one question:
    where I can find the images that are transferred and stored on my iPad or iPhone?
    (on an Android device it would be the “Folder for local images”)

    1. When you connect the iOS device with your OSX/Windows you should able to get the images from the qDD. I enabled sharing. The upcoming V0.2.3 for iOS will have saving to ‘Photos’

      1. Thank you for the saving photo fiction In the next iOS update … !

        Any fixes for the random blowouts ?

        1. I hope so, doing test with my iPad Mini 2 and also in simulator. I even needed to install in VM a Mountain Lion so I can test the iOS 5.1 issues.

  38. Zoltan,

    Thank you for this app its perfect i made already a donation,
    This is where i was waiting for, I used dsrldashboard already on a nexus 7 from my work but I am an Apple man.

  39. Hi Zoltan
    I have the same problem as Peter (post dated 27th Sept).
    I also have a Nikon D300 linked to my Ipad via a tplink 3040.
    The IOS app connects o.k and but there is a problem with the focus point set at the ipad in live view. The focus point can be moved and focused using the dashboard controls but when I trigger the shutter the camera doesn’t use the point I have set at the iPad and reverts to the previously set focus point that was set at the camera. I am using tripod based LV setting and af-s focus mode.
    Hope you can help



  40. Hi Zoltan,

    I have a long delay from 8 sec if I use Live View. I use Canon 1D Mk IV and iPhone 4 via MR3040. Do you know why it need so long time?
    I can’t use AF in the app. Nothing is happen.
    Is it possible that the last selected parameters are stored in DOF. I have to change every time the camera model and all other parameters. Perhaps you can fix it in the next update.


  41. I’m testing the app (v. 0.2.2) on iPhone 5 running iOS 8.0.2 connected to a Canon 5DII with a TP-LINK (flashed with v2.13).

    My main intention is for use with LRTimeLapse. However, Time lapses triggered externally (by emotimo or magic lantern) are stopped when the phone screen sleeps and triggering does not resume upon wake. It seems like the camera is trying to write a file but can’t. I need to remove the camera battery and cycle the phone’s wifi off and on in order to continue.

    Sometimes the camera will continue triggering several times before it stops working. Any ideas?

    I would love the app 100% if I could sleep my phone and/or minimize qDslr, continue to have the camera triggering, then open the app, connect again and make changes to settings later on.

    -LiveView does not work
    -A nice feature would be custom default settings or save most recent settings. (ex: open to LRT mode and default 1EV steps in LRT mode)

    I’d be happy to help with testing any way I can. It would be fantastic if this worked just a little more smoothly. Thanks again for the tremendous effort you’ve put in!!!

  42. One quick question:

    I did a late evening to night shoot tonight into the sunset. Now the histogram was very much the left (blacks) most of the shoot. The EV reading was around -2 to -3. Is there a way to exp compensate manually, as I wanted more information in the blacks. I did a test, setting EV higher on my camera, but it didnt have any effect. Thanks

    1. You could change the EV but that would affect the image and if using LRTimelapse mode it would compensate in next round. If using the LRTimelapse mode you should change the ‘Reference point’ value

  43. Hi Zoltan and all,
    The New Version seems to be out!

    Thanks for that, Zoltan

  44. I’m unable to connect my canon 600d with my iPad 4 or iPad mini 1 using the photecs Version of tp-link. My canon 5d Mark 2 is connecting without any problems. I have the newest Version of dashboard 0.2.3.

  45. Hi

    Have had great result with app until i upgraded to ios 8.1 the other day (was on 7) now it juat crashes after the first 6 frames have been taken. Please fix this.

    1. Ok seems to have been apples issue. The latest update that came out a few hours after my post lol fixed issues with ipad2. So all working again. Thanks 🙂

  46. I am on iOS 8.1.1 (iPhone 6) and a Canon 6D. I just downloaded the iOS qDSLRDashboard yesterday (Nov 26). I’ve got the 6D and the iPhone on the same wireless network, but qDSLRDashboard doesn’t appear to discover the camera when I tap the Canon Wireless button. It takes me to the control screen (LV, shutter, AF buttons on left, other buttons on right) with no image and just a small exposure meter at the bottom. The rest of the display is black. Same thing happens when I run Dashboard on my iPad. Has anyone had luck with this configuration?

    Interestingly, I get the same result over USB from my MBP (OSX 10.10.1).

    Regardless: Zoltan, thanks for your investment in this tool. If I can get it to work, it’ll be huge for me. 🙂

    1. What you mean no image? You must press the ‘LV’ button to enable live view. To capture an image you must press the ‘Capture’ button.

      1. Update: I’ve gotten the mobile app to work by putting the 6D in access point mode and connecting my iPhone to the wireless network it creates. (I also turned on RAW+JPEG rather than just RAW, which might have helped.) It still won’t work with both my phone and the camera connecting to another wireless network (say, my home wireless router). The 6D wireless connection is pretty flakey, so the latter mode is one I’d prefer, but it hasn’t worked out so far.

        I ordered a cheap Android tablet to see if I can get things working reliably over USB on the tablet. 🙂

  47. When I press LV, the screen stays black, and when I press the Capture button, the camera shutter doesn’t click. Pressing the Canon Wifi button does bring me to a new screen as if a connection has been established to the camera, but everything else behaves as if there is no connection.

  48. Hi Zoltan

    Just downloaded qdslrdashboard v 0.2.3 on my Mini iPad iOs 8.1.
    I tryed to connect my Nikon D90, D5200 and the 1 V2 via USB and the Apple Lightning to USB Camera adapter but had no success at all. I dont even have a USB button on the home screen of the app.
    What am I doing wrong?

    Any help is greatly appreciated

      1. It would be nice if this would be mentioned in the description, so I spent my money for nothing!

  49. Hi!
    I just got back to testing the iPhone app with my Sony A7s. The preview (post-view?) function works great, but I can no longer control anything on the camera. I get the pull down boxes for shutter, aperture, ISO, etc, but cannot change any of the values.

    Did something break in the latest rev? I thought I could change things before


      1. Update: The app works with my A7R, but not my A7S

        Set up both cameras the same way. One works, one doesn’t. Not sure why


  50. Hi Again Zoltan,
    I still can not get Dashboard to work – let me give you the details. I am trying to connect wirelessly to a Canon 6d using Dashboard v0.2.4. Here are the steps to set up my camera:
    1. Camera On
    2. Munu Button
    3. WiFi – enabled
    4. WiFi Function
    5. Pick Connect to Smartphone
    6. Pick Camera Access Mode
    7. Pick Easy Connection
    8. Then Reads: Connect to the following smartpone
    SSID: IWF / Encryption Key: 28230699

    Now to DAshboard:
    Tool Box pops up – Press Canon button – Controller page comes into view.
    4 buttons on left side
    9 Buttons on right side
    +- EV Scale on bottom
    Some of the buttons work taking me to different pages, but nothing seems to control the camera. What am I doing wrong.
    Thanks for your patience and help.

    1. I should add – on the connection screen after pressing theCanon button, I get the connection info showing only server, not the canon camera info.

  51. Hello Zoltan,
    Are there any step by step instructions on how to use qDslrDashboard software with TP-Link Wireless Router and Nikon D300 Camera? Is there any specific Firm Ware required for D300? Also, is there any specific model of TP-Link required?

  52. Zoltan,
    My questions above are for iOS 8.x on iPhone/iPad – Tahir

  53. hi Zoltán

    was wondering if the QDSLT iPad app will Support Pentax cameras any time in the Future? i would love to use it with the LRTimlapse Module you and Gunter created.

    keep Up the great work!

  54. Hi I have a canon t2i and a canon t4i and I can’t seem to get it to work with my Samsung Note 2 or my Dell android tablet or my HP android tablet or my iPad 2 or my iPad 3 I paid for the version that you have on the Apple store that one doesn’t work it opens up and tells you to search and you can press all the buttons you want and it won’t recognize the camera the same thing goes for the android I downloaded it from the Google play store and can’t seem to get it to work on either my phone or the tablets I’m hoping that maybe you can give me some advice to work this problem out I really love the application by watch by watching it on YouTube people that post up their experience with the app and they had a great turnout’s so that brought me to download it on the iPad and from the Google play store so I was just hoping that maybe we can get this to work with The Canon T2i and the Canon T4i even though I can’t get it to work like I said I’ve seen a lot of good videos and people had gotten them to work you did a great job and hopefully I can get mines to work thank have a great day

  55. Hi Again Zoltan,
    Guess I’m wearing you out with my problem with Dashboard and 6d wireless and you don’t want to hassle with it any more. I understand.

    1. I got a tip from Gunther (I didn’t have a Canon 6D), here is what he said:
      I use the Canon Utility to establish the connection first, otherwise you won’t be able to pair the devices.
      After the connection is established, you don’t need the app anymore, then you can just connect wifi and launch DDB.

      1. Gave Gunther’s system try – it works sometimes and sometime not. Also downloading any sizable file from the camera takes a very long time – much too slow to make DDB usable.

  56. no ‘tab’ for usb connection on iphone 6 nor galaxy 3 – desktop mac works just fine. nikon D810.



  57. Can I use this App. with Sony Alpha 7r?
    If yes can you kindly give me some tips & tricks?
    I aldeada download your App from Apple Store
    Carlos Santos

  58. hi Zoltán

    maby you missed my Last post so here it is again.

    was wondering if the QDSLT iPad app will Support Pentax cameras any time in the Future? i would love to use it with the LRTimlapse Module you and Gunter created.

    keep Up the great work!

    1. I would like to add support for Pentax DSLR but I don’t own one and Pentax does not release documentation for developers. Actually except Nikon and Sony none of the vendors provide documentation. 🙁

    1. I answered you in mail but here to. I was doing some test with it (I actually have a pair of USB wireless dongles) but there is no driver for Android, iOS. Another point is that with this solution there is a very small overhead on packets (only 4 bytes on each PTP packet)

  59. Not work on Nikon J4 for me
    I have tested..
    Anyone can work on Nikon J4?

      1. Is it possible to help you get the J4 live view data ?
        I have J4
        How can I help the program

        Thank you

  60. Hello, i have ios 8.0.2 and a Nikon p600,
    I can make fotos but i can´t see Live view and other settings 🙁 can you help me?

    1. Nikon only releases documentation for their DSLR line so I don’t have any information about the P600 live view data structure. Without it I can’t add the code that would handle the P660 live view.

  61. will QDSLR for IOS transfer NEF files from D810 to camera roll…everytime i hit save they dont show up in actuall camera roll.

  62. Hello!
    Does the aktual App work with an D7100 over the WU-1a adapter and an iPad Running iOS8?

    Thanks for Answers.

  63. Hi…great app..but can anybody help me know how to use bulb mode from the app..am using iPhone 6 with canon 6D…I couldn’t figure it out..I can’t choose the time of the shutter I want.it doesn’t show in the app that am on Bulb mode

  64. Thank you Zoltán…it would be Great…when do you expect the New Vorsaison to be?

  65. Hi Zoltan!

    Thanx for your wonderful work !
    I just bought the appfor iphone 5s running ios 8.3.1.
    Flashed correctly my MR3040
    When I try to connect to my D300, it won’t: “Failed to connect to Nikon wireless DSLR”
    I also reseted the D300 to factory defaults. no success
    I’m stuck ! any help appreciated 🙂

  66. Hi,
    I download the apps,but cannot use the cable to my canon 60d , no Screen in show the iPadmini

    1. On iOS devices only wireless connection is available, either with the built in camera wireless or with the TP-Link MR3040 portable router using the OpenWrt firmware and ddserver.

  67. Dear all
    i need help i have canon 5D mark 2 and TP-LINK 3040 AND IPAD
    so how to control the dslr from ipad wirelessly

    TANHKS 🙂

  68. This is a great sw for iOS to control my Nikon. One question: does it support USB adapter w/ iPhone without wireless wu-1a?

Comments are closed.