qDslrDashboard V0.1.6

Managed to recover from the HDD crash so here is the V0.1.6 with bugfixes.

  • more fixes to folder selection
  • fix for the Connection screen ‘Network’ and ‘Wireless’ button long press not working
  • added time selection dialog for BULB shooting (if 0:0.0 is entered it will run until the users cancels it)
  • moved the not much used LrTimelapse settings into a settings dialog
  • added a ‘Capture sample’ button to LrTimelapse screeen (only visible if the ‘Auto Holy Grail’ is not started
  • added a new method for changing shutter/ISO for Canon users.  It can be enabled in the new LrTimelapse settings dialog. Please Canon users test it . I had very good results with the 650D
  • some fixes for the image review working. qDD will prioritize JPG image review over RAW (probably will add a settings that can change this). RAW will be only displayed if the selected camera image format is set to RAW
  • some memory leak fixes in the image viewer
  • fix for a crash that occur while re-sizing the window when an image is displayed
  • added media playback controls
  • probably there are some more small fixes that I can’t remember

I also detected an error in the ddserver code that lead to connection break (USB and wireless to). I will publish later today or tomorrow a new MR3040 firmware and also a new method for updating the ddserver package on the MR3040 without flashing (this will only work if the MR3040 already has the V0.2-12 ddserver version)

Here are the files:

Android ARM: qDslrDashboard_V0.1.6_Android_Arm.apk

Windows x86: qDslrDashboard_V0.1.6_Windows_x86.zip

Windows x64: qDslrDashboard_V0.1.6_Windows_x64.zip

NOTE: Before starting qDslrDashboard please install the included vcredist_x86(x64).exe This need to be done only once after installation.

NOTE: For Windows XP i will later build a V0.1.6 as the current one will not work

Linux x86: qDslrDashboard_V0.1.6_Linux_x86.tar.gz

Linux x64: qDslrDashboard_V0.1.6_Linux_x64.tar.gz

NOTE: I now included the OpenCV, LibRaw and libusb libraries. If you need to change or use your own then delete them from the Qt_Libraries folder.

OSX x64: qDslrDashboard_V0.1.6_OSX_x64.dmg

46 thoughts on “qDslrDashboard V0.1.6”

  1. I download the 0.16 and like to try it. But I cannot found LRTimelapse. Greetings Josef

  2. it was my mistake – LRTimelapse still there. I tried the 0.16 with EOS 5D Mark III. the error 70 after about 80-100 shots still come again.

  3. Just to clarify: is this “new method for changing shutter/ISO for Canon users” only applicable to LrTimelapse settings?

  4. Hey,

    I’m confused: Is there a way to let qDSLRDashboard (or the DDServer) to do the actual triggering for the timelapse?
    As far as I have understand it, I need an external interval trigger to actually “press the shutter button” and qDSLR Dashboard to change the settings.
    Is that correct or am I missing something probably pretty obvious?
    If not, will there be the option to trigger the timelapse shots with the DDServer via qDSLR Dashboard in the future?

    Thanks !

  5. Thank! That’s what I was hoping for!
    Any idea regarding a timeframe ? (6 month or more like a year? just an idea would be great)

      1. Great !!
        Looking forward to the next release with interval timer very much.
        Will interval and LRTimelapse Holy Grail continue, even if qDSLR Dashboard is disconnected ??


        Kind regards
        Niels Göran

  6. Is there away to capture errors from DSLRDashboard? Maybe I should go ask this in the forum ;-). Yesterday in attempting to use it with the wifi router I kept clicking on the network button once connecting router expecting it open the camera control window. No matter how reboots, cable checks, wifi checks etc… I never could get it go. I could not find a place to see error logs etc… Even if its with the DSLR, is there a syslog file for android someplace?

      1. I tried the long push, and set the address.
        It seems to be almost an every other attempt. I got to work last night but did nothing different than the other 5 to 10 tries.

        Android is the platform, and I could see the router webpage and login and it did show my canon camera attached.

        So I was hoping there someplace in the logs I go look.

        1. Please use the forum for error reports and help.
          >>Android is the platform, and I could see the router webpage and login and it did show my canon camera attached.
          Where did you see your Canon camera attached?

  7. My gut says its not software, buy maybe connectivity. But I was on the router, I could see the camera and the webpage. And the router saw the camera. So I thought, where can I go see what my tablet is saying is not happening when push button 2 and nothing changes. I tried a different USB cable from the tplink router to the camera as well. rebooted etc…

    I did not try tethered, as I really didn’t want to leave my tablet out in the bean field, didn’t bother me leaving the camera as it setup just over foliage.

  8. Can not save ssid name or password turn off and on again back to default !

    1. All working with this new Version the last version had the problem with not saving the ssid name and password !
      When you turned the MR-3040 off it would loose the SSID name and also the password if you set one.

      Now when you turn the MR-3040 off and back on ,
      on the android tablet in the WiFi settings you don’t loose the password or the Ssid name you made.
      Thank you For fixing that !
      This new version Rocks !

      Hoping to see firmware for the TP-Link MR-3040 and QDslrDashboard for IOS in the future !
      Thank You !!!!!!

  9. This looks like it has great potential. I have a few bugs to report that I will do through the forum. I donated so that the future work on this application is encouraged!

  10. Hello, Looks like a brilliant app. Great job!! I would like to ask if you plan to add full support for Nikon COOLPIX A.
    Applications are okay connects via adapter WU-1a to Nikon Coolpix A, you can download pictures to change the camera settings, but unfortunately does not work LiveView and shooting, camera lens remains retracted.

    mi phone is Xiaomi Mi2S.

    Thank you!

    1. Will need some log files (also need to add some debug code for this) to see if I can add LV and capture (probably it could be added) but there is no SDK so will need to guess.

      1. what kind of log files do you need? if theres a way to help let me know! I have a coolpix a and the wu-1a adapter and I would love to see support.

  11. Hello there,
    Today i found your very hot piece of software. As i personally own a Nexus7, a Nexus4 and a NikonD7100 with a brand new WU-1a wireless adapter, i was first a littlebit disappointed with the app provided by Nikon and until today looking for an alternative.

    As i am programming in my job too, i recently installed a network-sniffer to build eventually my own extension for what i thought was missing in the Nikon app.

    But as i saw today, you did this before and with such a high quality, i can only thank you soo much. I am very proud of you, providing your masterpiece as an openSource software. I wish so many more peoplr creating such wonderfull things would think in the same way. I could imagine the humanity as we know would be much more experienced that way, as the development goes much faster this way (see linux and other openSource software).

    Please tell me the difference between the dslrDashboard hosted on googleCode and qdslrDashboard on this site, as they have different versioning numbers.

    1. DslrDashboard is Android only mostly Java with some C code.
      qDslrDashboard is cross platform built with the great Qt Framework in C++.

      1. Can I get qdslrdashboard on Android? Play Store only gives me dslrdashboard (without the “q”). I would like to try the program on Sony A7ii, and I understand I need the “q” for that!



  12. Great app, it’s saved me from buying a field monitor, haha!

    One suggestion, though. Would it be possible to add a 16:9 overlay to know where the borders will be when recording video?

      1. Oh, I got a bit confused, I was commenting on the DslrDashboard Android app that can be downloaded through the play store. You’re the dev for that one too, didn’t realise you made two different ones.

        Now that I’ve had some time to use qDslrDashboard, I prefer its UI and the fact it has the AR overlay, but I think I’ll still use the other one, because the live view feed isn’t as compressed and has smoother frame rate.

  13. I just installed DSLR Dashboard on my ASUS TF101 and then connected it to my Nikon D5200. While all the camera functions seem to work through the program, I can’t see what my camera sees, just a black screen. Also the camera and AF icons on the upper left are highlighted in red. I can still take pictures, I just can’t see what I’m taking pictures of. Any ideas?

      1. Hi Zoltan and thanks for the quick response. The program I installed is DSLR Dashboard.

        When I click on the Lv icon in the program I get an error message that says – Liveview Prohibition – “The Exposure Program Mode is [Scene mode] or [User Mode]. I’m not sure I know what that means but my camera was in Scene Mode when I tried.
        Also, when I try to switch to LiveView on my D5200 while connected to my tablet, my camera gives me the following error message “Cannot start live view at current settings or under current conditions”. I’m connected by the Nikon USB OTG cable that came with the camera.

        I don’t know what else I can tell you. Cheers.


        1. Please use the forum.
          Switch the mode other then Scene or User and it will enter LV.
          I’m only working on qDslrDashboard so please use that one.

  14. Unfotunately, V0.16 crashes very often. I use it on a Nexus 7 (2012) on Stock Android 4.4.4. with a Canon 6D. No difference if I connect via WiFi or via USB. Yesterday it crashed via USB after ca. 200 shots. I tried several times, always crashes after ca. between 50 and 200 shoots.

  15. Hi peeps.i can see a lot of works gone into this but im not a bright spark when it comes to computers and software.
    im using a d3100 and downloaded the 0.16 version but still wont connect or recognise my camera.please help.matt

  16. Hello, I have a problem with DslrDashboard V0.1.6 and my Canon 6D.
    I start all process with Holy Grail, start the intervalometer, the Samsung tab connect to wifi and start withut problem, change time exposure to limit but don’t change Iso value in next shot.
    I try to make this in Sunset o Sunrise and result is same.

    What’s the problem ???


  17. V0.16 Linux 64bit can’t run on Ubuntu 14.04.
    $ ./qDslrDashboard.sh xcb
    $ ./qDslrDashboard: symbol lookup error: /home/DslrDashboard/qDslrDashboard_V0.1.6_Linux_x64/Qt_Libraries/plugins/mediaservice/libgstmediaplayer.so: undefined symbol: _Z22qt_gst_object_ref_sinkPv

    did I miss anything?

    1. Probably some gstreamer dependency

      Check with:
      ldd /home/DslrDashboard/qDslrDashboard_V0.1.6_Linux_x64/Qt_Libraries/plugins/mediaservice/libgstmediaplayer.so

  18. What is the “Canon Method”?
    What can i do with it?

    When i work with Canon 70D Wlan i cant Lookup my mirror.
    Do you have any Ideas?


  19. Hi there
    thanks brother for writing this amazing app n making it free for us all
    i installed v 0.2.3 and it worked flawlessly on my 6D using its integrated WiFi!
    i have few questions like
    can i use firmwares like Magic Lantern and their features like Silent Pictures on 6D or any camera connected via WiFi?

Comments are closed.