qDslrDashboard V0.2.3

Released a new qDslrDashboard version V0.2.3

  • fixes for the Canon wireless communication
  • added a wakelock to Android when LRTimelapse is started (now it should work even if the screen goes off)
  • added focus points definition (works with Nikon and Canon – will see to make a tutorial)
  • changed the ‘Image viewer’ loading notification
  • added an option to disable image info download for images that are already on the camera SD card (you can still load them by pressing the ‘Refresh’ button in image gallery)
  • added a generic PTP class that should work with non Nikon and Canon DSLR that support PTP (I can’t test this as I only have a Nikon and Canon)
  • other small fixes

Files can be found on the Downloads page

In the upcoming days will also upload a new iOS version with these changes and also the ability to save images to ‘Photos’ – still working on it

180 thoughts on “qDslrDashboard V0.2.3”

  1. Manuel or training video

    I just brought the dslr dashboard today. It seems not working well with Nikon D810, on Df seems ok.
    Any Manuel in PDF or training video to explain the various function and setting etc.

      1. Dear;
        I connected d810 to samsung s5 via otg.but cand see anything..screen is blind..dark.. i can only see the control buttons nor the not any screen wiew..if i press live wiew dsrldasboard stopped ..

          1. I have the same issue with my 810 and s5. I downloaded app from play store. Is this not the current version? If not where is the latest?
            Thanks Guy

          2. I downloaded from the Playstore for my Android devices (Samsung Tab 2.0 7, and S3). The version tells that 0.30.33, which is updated on Feb 18, 2014. This version crashes when connected with D810. D90 works, but not 100% though.

            The version number seems newer than V0.2.3 in this page. Which one is newer version 0.30.33 or V0.2.3?

  2. Thank you for this delivery, but:
    – I could not find how to define focus points.
    – what’ s the purpose of ‘1’ and ‘2’ within a circle that are displayed in the bottom left corner of the Lv screen?
    – frequent crashes when trying to go back from live view to application settings using the button in the right side of the screen. No crash when using the equivalent button within the camera properties display.
    Android version with Canon 5D MK II

    1. The ‘1’ and ‘2’ buttons are the focus point button. Long press to remember a focus position, single press to move to that focus position.
      On what platform do you use it?

      1. Platform: Android 4.4 on Samsung Galaxy Tab Pro and a Canon 5D Mk II camera.
        Thank you for your explanation. Unfortunately it looks as if focus memory is not performed or lost. When I long press on one of those buttons it becomes red but if I focus on antoher point then the red button becomes white and pressing on it does not focus on the previous chosen area. To make this test I was in flexi-zone focus mode as the focus rectangle can be seen only in this mode for my camera.

        1. If you press the AF button then the focus points will be cleared. There is no way to get the current focus point from camera. So the application remembers your focus movement that you do with the focus buttons. On Canon for focus movement you only have 3 choices (small, medium, large) and if you remember a focus point that you made with medium movement and then after to a large movement it will clear the remembered focus points. This is up to the Canon focus movement that is available to application. On Nikon you can define the desired movement step.

          1. Though a focus point has been set (it is red) a single press on it has no visible effect: the focus rectangle stays where it is and does not move back to the supposed saved position.

        2. Probably it is a wrong definition, it will move the lens focus ring not the focus rectangle. With the focus buttons you move the lens focus the ‘1’ and ‘2’ buttons remember that not the position of the focus rectangle.

          1. OK. Then nothing happens: I focused, saved into ‘1’, manually moved the focus ring to unfocus, recalled ‘1’ but did not obtain previous focusing. Did I miss something?

  3. Hi,
    the new version shows by starting nikon-button: “Tring to connect Nikon 1WUa / b / D5300 while a Nikon D800E is connected via USB.” Than: “Failed to connect … ” I tried the previous version 0.2.1 and it runs correctly.
    Meanwhile: Thanks for the great Software!!!
    Greetings, H-J. Schodry

    1. The USB button is when a camera is connected with USB the ‘Nikon Wireless’ button is for connecting to Nikon WU-1a/1b/D5300 and D750 wirelessly

      1. Is this Version working well with the d750? When yes also in the upcoming iOS Version? Thanks for your work and a short Message.

          1. Hi Zoltan,
            I just discovered your application and love the idea. I am using a Nikon D750 and over USB everything seems to work fine running a MacBook Air with 10.10.1. Going to full screen or back seems to black out the screen and I need to close the app to get it to work again. Not a major issue.

            However, connecting to my D750 wireless is an issue. I get the “Failed to connect to Nikon Wu-1a/1b/D5300″ error message. I am not sure what I am doing wrong.

            This is what I do:
            – I set the camera in WiFi mode (default off)
            – I connect my MacBook to the D750 access point. The MacBook shows a connected WiFi point
            – I press the button in qDSLR and get the error message

            Any idea how to fix this?

          2. Did you maybe change the camera IP address? If yes then long press the ‘Nikon wireless’ button and in the upcoming dialog enter the camera IP address. By default the application uses the address.

      2. I am having the same problems as Schodry above except I am trying to connect to a D600.

        I am trying to connect using the Nikon wifi option. The wu-1b is plugged into the D600 and the little green lamp blinks at a regular interval.

        As per the previous version (V02.2) I still get “Failed to connect to Nikon Wu-1a/1b/D5300” error message.

  4. Hi Zoltan,

    I have bought the qDslrDashboard iOS version, but i have no idea why i can’t get it connect to my Canon 6d.

    Appreciate if you could show me the way. Thanks

    1. Enable the wireless control function on the 6D.
      Connect the iOS wireless to the 6D wireless.
      Start qDD and press the ‘Canon Wireless’ button.

      1. Hi Zoltan,

        Yes, i have enable the wireless control function on the 6d (connect through smart phone option), connect my iPad to the 6d wireless and start qDD and press Canon wireless button. However, qDD can’t search the 6d.

        1. I asked Gunther who uses the 6D with qDD and here is his answer:
          ‘I use the Canon Utility to establish the connection first, otherwise you won’t be able to pair the devices.
          After the connection is established, you don’t need the app anymore, then you can just connect wifi and launch DDB.’
          Hope this helps.

          1. Works perfekt for me with iOS and OSX and Canon 6d. No Canon Utility necesery for pairing.

  5. Hi, will the new iOS version include a fix for the iPad 1 for use with Canon 600D as per my iPad crash report I reported in the forum board?

  6. Hey zoltan Theres no record movie in live view on the qdslrdashboard for Nikon d3300, any suggestions or fix update? Thx great app

    1. If there is no ‘Movie recording’ that means the camera does not support that PTP command. The D3x00 are budget models with only a limited set of PTP commands/properties.

  7. Hey Zoltan,

    Is there a link somewhere that shows what is enabled in the IOS version versus the Android? I am ordering a iphone 6 plus and wondering if I can switch to it as my tablet and phone, or if I should stay with my phone separate from my tablet for now. And still carry both when I go out to do a timelapse .

      1. I am connecting my 7D to my iPad via USB and it’s not working at all. Are you saying that if I go wireless it will work? thank you in advance, Piccia

        1. The iOS devices don’t have an USB port so only the wireless connection will work. The ‘Camera connection kit’ SDK is not available for developers so it can’t be used in application.

  8. I have a Nexus seven 2012 model, VO.2.3 downloaded (14.43mb) but does not install. After it downloaded on my Nexus seven I noticed that the icon for the download was not a little android guy.

  9. I am a bit confusion .. what the difference between qDslrDashboard and DslrDashboard ? i want to use with TP-LINK TL-MR3040 but without success in the moment .. first try yesterday … i have a nikon D300s and samsung galaxy … i think the problem is i downloaded yesterday a old version of OpenWRT .. i have vesrion 1 tp link and i download the v1 factory.bin but not the newest … i saw here V0.2-13 what i can do ? i have the DslrDashboard apk in my mobile can i download the newest version and work ?

    thank you

      1. Thank you Zoltan i wish to work this … i am very exciting to do that … i see …

        1. Update: i done everything who Zoltan said and everything work like a charm!!! i use the Dslrdasboard because i can focus by click on the screen and also i can review the picture better than qDslrdasboard …
          Thank you !!!!

  10. Hey Zoltan, my Nikon D5200 works well with DslrDashboard via WiFi, but the connection fails with pDslrDashboard. Any help ?

    Thank You

  11. Hello. I have Widows XP SP3 Comp. 2600 – 32 bit and I’m trying to tether an EOS 40D. I downloaded Qdslrdashboard v 0.2.3 Windows XP86x and Zadig Utility. First installed WinUSB driver according your instructions, then run vcredist x86 (x64) and, finally, launched Qdslrdashboard with the executable with the camera on USB connected to the computer.
    I can only see some functions of those reflected in your instructions page but not the whole and only some of them “seems” to work. I can shoot, but I can’t see any image even with Live View activated.
    What can be wrong?…is EOD 40D supported?. Thank You.

  12. Hi Zoltan, ist es auch möglich die Canon 6D quasi als Live Monitor für Videoaufnahmen mit deiner App zu nutzen? Danke und lieber Gruß…Carsten

  13. Hi Zoltan, thx for the quick reply and sorry, that i asked in german. Is there any tutorial or description how to connect the Canon 6D wireless to my Samsung Tablet? I got both apps. Dslrdashboard and qdslrdasboard. Thx

    1. Np for German, I understand it perfectly only speaking and writing isn’t so good.
      Unfortunately I had no chance yet to test a 6D or 70D but Gunther wrote me this:
      I use the Canon Utility to establish the connection first, otherwise you won’t be able to pair the devices.
      After the connection is established, you don’t need the app anymore, then you can just connect wifi and launch DDB.
      Hope one day I can get my hands on a 6D for few days and improve this.

  14. Zoltan,

    Is there a “Compatible Cameras” list that shows which cameras are fully or partially functional with dslrdashboard. I own the Nikon D7000 and I see some posts about people using it, but no detail on how. I have purchased the MR3040 wireless router and waiting for it to arrive today. I appreciate all your efforts.


  15. Donation sent. People should support the people who do the work and not just use freeware when they can afford to help out the guys n gals who do this work. Thanks for all your efforts Zoltan!!


  16. Hi Zoltan,
    thank´s for your great work. You are the man! 🙂
    I have a D750 since last weak, will this Camera supportet in your next update (Android, Nexus 5)? If i can help you with any test, let me know.

  17. Hey,
    First of all, great work. This app really helps you relax during timelapse. If not previously you need to monitor and just the camera every few minutes.

    I have a question, is it possible to do in the auto-holy grail where we can put ND filter for day for motion blur effect, but when the sunsets it will tell you to remove the ND filter for night time motion-blur effect as well?

    Again, great job! Cheers

  18. Hi Zoltan
    appreciate your great effort with the great app
    and i was wondering does the app support the new Nikon d750?
    if not have u made any updates to make it work?
    thanks in advance

      1. hei zoltan Hubai, D750 works not in movie mode? by ipohne 6 over wireless……..pfotos no problem

      1. Unfortunately, the iOS Version 0.2.3 also will not work with Canon EOS 5D Mark III and EOS 7D. What can i do?

  19. V0.2.3 on Samsung Galaxy S3, Android 4.1.2 connected to a Nikon D300 via USB.

    Hi Zoltan,
    everything else works like a charm in Live View (e.g. focusing), but I do not see the Quick Focus Buttons. And the button “Focus BKT” is greyed out.
    How to get into Focus bracketing?

  20. Panic!!!

    Just upgraded my IOS version on iPad to 0.2.3 and now it won’t run at all. It closes immediately upon opening yet when you ‘double click’ to see running apps it shows as running but taking a picture I took a week or so ago 🙁

    Holding back ‘upgrading’ iphone until it starts working again on iPad

    Hopefully an easy fix

    1. What iOS version is your iPad? I did test on 8.1 on my iPad Mini 2 and the older versions where tested in simulator (till iOS 5.1) and all worked fine.

      1. IPAD3 64gb – only app that doesnt work is DSLR 🙁

        I have de-installed the reinstalled with hard reset in between, same fault all the time, black screen, app briefly flashes up then disappears – appears to be running as black screen in the background

  21. Same problem with not starting app on iPhone 5 and iOS 8.1 !!

  22. Meant to say that I am running IOS 8.1 and DLSR was working on the previous version of DSLR, only after I updated to 0.2.3 this morning has there been the issue 🙁

  23. Zoltan

    Have re-installed the iPad from Apple ios8.1 installation and restored apps from cloud and this appears to have cleared the issue – don’t know what was causing it 🙁

  24. Zoltan

    I spoke too soon 🙁 the app will run now, sometimes the first time you open it, sometimes the second time, but mostly the third time that you open it.

    the app isn’t crashing on the iPad, it is simply minimising to the background instantly where it is running but you are unable to access it. Clicking on the app icon will bring it up working eventually but it is rather hit and miss 🙁

    Iain Morrison

  25. I’m not sure if this has been fixed since version 1.7, but Mac has an issue with non responsiveness if the computer goes to sleep, or if the screen goes black to save battery. It will stop running the software properly, and potentially stop the LRTimelapse function from metering. There have been occasions where I had to log into my computer, go into qDSLR, sometimes I would have to replug in the USB to get camera control again and restart the holy Grail mode.

    This very well may be a USB function on the Mac, but it would be nice if there was someway that qDSLR could keep Mac from going into battery save mode, or causing the computer to log itself out during non-activity. I generally just watch the jPEGs roll in since the USB is perfect for watching every frame, and I hardly have to click view next JPEG. Thus the inactivity.

  26. Hallo Zoltan Hubal

    Benutze qDashboard Vers. 2.3 auf einem PC Win7 Prof. und auch unter Android, auf einem Acer Tablet A510
    Als Server wird ein TP MR3040 mit Server Firmware Vers. 2-13, genutzt.
    Zunächst das erfreuliche!
    Es werden zwei Nikon-Kameras, D7000 und D7100, parallel für 3D-Aufnahmen betrieben.

    Die Kameras sind über einen USB-Hub mit dem TP-MR3040 verbunden.

    Es funktioniert alles einwandfrei. Die Kameras können nacheinander angemeldet werden und sind eineln ansteuerbar
    und funktionieren. Sowohl auf dem PC oder alternativ unter Android, auf dem Tablet.
    Auf diese Art wurde eine Zwei-Kamerasteuerung möglich und dabei habe ich auch die Funktion des Befehls ‘Synchronized capture’
    aktivieren können.
    Auch das hat anfänglich, auf Anhieb, einwandfrei funktioniert. Beide Kameras konnten problemlos synchron ausgelöst werde, egal von welcher
    Kamera aus, der Befehl Capture, aktiviert wurde. Nur so war es möglich, bewegte 3D-Bilder, aufzunehmen, ohne das der 3D-Effekt
    darunter Schaden genommen hat.
    Hoch zufrieden habe ich die Aktionen ein paar Tage ruhen lassen, um mich dann später noch mals damit vertraut zu machen.

    Aber leider bekomme ich die Funktion ‘Synchronized capture’ jetzt nicht mehr ans Laufen. Der besagte Befehl wird vom System einfach
    ignoriert. Egal was ich mache, alles andere funktioniert einwandfrei aber es ist keine Auslöse-Synchronisation mehr zu aktivieren. Einzelauslösung
    der Kameras – kein Problem. Auch eine Neuinstallation auf beiden Systemen brachte keine Änderung.
    Lieber Zoltan, mach doch bitte mal Deine Trick-Kiste auf, vielleicht hast Du eine Erklährung für mein Problem – ich bin ratlos!

    Danke für Dein Bemühen!
    Gruss Wilhelm

    1. Please send me an email with the camera settings (mode, shutter, iso, etc). I have a D7100 and D5000 so I can try and simulate your configuration in hope to find the error.

    1. I have the same problem – no LIVE VIEW on ma Canon 500D.
      When i connect directly my camera with notebook – dslrdasboard working good with live view.
      When i try connect throgh TP-LINK (my notebook or smartphone on android jelly bean) – after few frames – dslrdasboard exit to main menu.
      I try use two versions of dd-server and Qdslrdashboard – and i got the same problem.

  27. Hi Zolton,
    qDslrdashboard is great app no doubt about I was so happy that this app is available on ios also but I got disappointed that it doesn’t support USB. Since I am using 2 Camera D7000 and D800 both camera doesn’t have wifi connection. Even with extra adapter also camera can’t have wifi connectivity so I can’t use this app on my Ipad . I appreciate if you include USB connectivity for upcoming ios versions .

    1. I would love to include but iOS devices does not have USB port and the CCK is not available for developers. If Apple opens it for developers I will for sure add USB support. You can use both DSLR with the TP-Link MR3040.

  28. I’m unable to connect my canon 600d with my iPad 4 and iPad mini1 using the photecs version of Tp-Link which i just bought this week. Connection of my canon 5 d mark 2 works without any problems. I have the dashboard version 0.2.3

    Could you help me with your advice? Thanks.

  29. Hi Zoltan,

    first of all, thank´s for your great work. I installed TP-Link MR3040 ddserver and qDD on Android. Both work like a charm with my Nikon D5100.

    But, I have a problem with qDD 0.2.3 on Windows 7. The app crashes when I attempt to connect to DD server. Here is the problem signature from windows :

    Problem Event Name: APPCRASH
    Application Name: qDslrDashboard.exe
    Application Version:
    Application Timestamp: 543a1f8a
    Fault Module Name: ig4dev64.dll
    Fault Module Version:
    Fault Module Timestamp: 4aba7141
    Exception Code: c0000005
    Exception Offset: 00000000000055ec

  30. Hi Zoltan,
    i’ve bought your App for my Ipad and it works great with my Nikon D750. I am taking pictures in RAW and Jpeg simultaneously but I want only the Jpegs to be shown on my Ipad. I am using the Ipad as a control monitor and as soon as i take a picture it is shown as a Jpeg on my tablet. So far, so good, but when i scroll back to have a look at the pictures i made just before, both the Jpegs and Rawfiles are shown . Is there any adjustment i could do for limiting the monitoring to the Jpegs only?

    1. Hi Raph,
      Can you give me a hint to get it to eork on D750?
      It does not seem to connect. Do I need the WU adapter?

      1. Enable wireless on your D750. Connect your device wireless with the D750 wireless. Start qDslrDashboard and press the ‘Nikon wireless’ button

  31. Szia Zoltán,

    Nincs véletlenül egy lista, hogy melyik androidos tableteken fut, vagy volt kipróbálva az app?
    Nekem egy Dragon Touch 7″ Y88 Android 4.1 dual HD screen HDMI -em van, és az alkalmazás nem indul el.

    Előre is köszönöm válaszod!

  32. I am growing increasingly frustrated trying to get this to work. I have a 5D mark ii and an iPad. I bought the MR3040 and the flash was successful.

    All of the documentation shows different screens than the main screen on qDslrDashboard. All I get is “searching for DDServer” Do you have some Step-By-Step documentation for the qDslrDashboard and how to connect it with the MR3040? I have just wasted about 2 hours of my life trying to figure it out for myself from scattered information on the web.

    1. Connect your iOS device wireless with the MR3040 wireless.
      Connect your DSLR with USB to the MR3040 and turn in on.
      Start qDslrDashboard and press the ‘Network’ button. It should find the camera connected to MR3040.
      If the camera is not found long press the ‘Network’ button and enter ‘’ as IP address.

  33. Hi Zoltan,

    You are a brilliant engineer! Come to the USA and make a lot of money 🙂

    Do you know if anyone has documented how to use the focus stacking capability? It is not intuitive, at least, for me.

    Thanks so much.


    1. Hi Larry,
      Sorry for my english. translation by Google:
      I put in the Start Live View first exposure then use the arrows (Thanks Andres: D) the start and end of the field range (press the round circles with numbers 1 and 2 longer at that position, they are red. shown)
      until then I go to the FocusBKT and joint function the start and end point Focus on the right side in the query.
      then I put the left the number of images, the focus step is calculated automatically, select the direction (or infinity Closest & subject position of the points.
      Trigger and be amazed.

  34. PS…I should have added that I’d hire you in a second!

  35. I must say new version is working great with my Canon 5D mark ii and Google nexus 5 android device via USB. I still couldn’t make tp link work with it though 🙁 but at least lrtimelapse functions are now working great after I installed new version and purchased Pixel Timer intervalometer. The intervalometer was the problem really, not the dashboard. Congratulations on your such a great tool, just donated 25 Euros to your PayPal account. Would love to have tp link WiFi working but I just don’t know what could be wrong. I posted my problems on the forum but unable to fix it 🙁

  36. Hi.
    Great stuff like all the time.
    i wonder if you can easily increase the EV compensator to +- 10ev it will be great for ND1000 shot. Don t have to calculate the exposure anymore :).


  37. Hi,

    Sorry to bother you. I have V0.2.3. When I tap the first button, it says “Searching for DDServer” but does not seem to be able to see my new Nikon D750 (sorry, not sure if that’s how it works). And when I tap the NIKON button, it keeps saying “Trying to connect to Nikon Wu-1a/1b/D5300” and then “Failed to connect to Nikon Wu-1a/1b/D5300”. Not sure if that is due to I used to have a Nikon Wu-1a?

    Do you have some idea or suggestions for me? Thank you so much!

    Kind regards,
    Philip C

    1. Sorry, forgot to mention I have iPhone 6. Thanks!

      Kind regards,
      Philip C

    2. If you wan’t to use the D750 built in wireless then you need to pair your iOS device wireless with the D750 wireless then in qDD press the ‘Nikon Wireless’ button. By default the Nikon IP address is if the D750 IP is different then you need to long press the ‘Nikon Wireless’ button and enter the IP address.

      1. Hi Zoltan,

        Got it! It works! Thank you so much!!!

        Kind regards,

  38. Awesome! Got my TPLink setup and configured with my Nikon D800 and DslrDashboard on my Ipad 2 (IOS 8.1) Straight forward setup – anyone not sure on “how to” check the forums on this site, plenty of help. Thanks
    (Donation on it’s way)

  39. Hi there
    thanks brother for writing this amazing app n making it free for us all
    i installed v 0.2.3 and it worked flawlessly on my 6D using its integrated WiFi!
    i have few questions like
    can i use firmwares like Magic Lantern and their features like Silent Pictures on 6D or any camera connected via WiFi?

  40. Problem:
    With Android Lollipop (5.0) i’m not able to get a working connection to the D750. But it’s not only this app. This also happens to the original Nikon Wireless Utility-App. So I think Google made some changes to the WiFi-integration in Android 5 you should have a look at.

    Would be nice if you could fix this soon.

    However, thanks for this amazing app!

      1. thx mate, this solution worked for my n7 2013 5.0 and nikon d600

      2. Unfortunately the wireless connection between the Nikon D750 and the Nexus 5 (5.0.1) doesn’t work at all.
        Using USB works great.

        1. I have a confirmation from Gunther that D750 wireless is working.
          Do you pair your Nexus 5 wireless with the D750 wireless?
          Did you change the IP address of the D750 (by default is used)?
          If you changed the IP address of the D750 then long press the ‘Nikon Wireless’ button and enter the IP address.

          1. Hey Zoltan & Merry Christmas

            The wireless connection between the Nexus 5 with Stock Android 4.4.4 worked pretty well. After upgrading the Nexus 5 to Stock Android 5.0 ( now 5.0.1) i´m not able to connect wirelessly to my D750.

            I´ve nothing changed on the camera.
            Some few times (every 20th try or around this) it connects, but i´m not able to do anything and the WiFi-Symbol shows an exclamation mark.
            Also, if i got connection, the connection drops after a short time and reconnects and so on.
            I´ve got no problem with my Nexus 5 on other WiFi-Networks, as my home Wifi or the Wifi from friends.

            I´ve tried different typs of connecting. No one worked for real.
            * No password (Sometimes it works, as i described above)
            * WPS – Push (Same as above)
            * WPS with Pin (Same as above)
            * Password set, via the Nikon Wireless Utility-App, when i got connection with the no password-method (The connection drops. After that no connection possible)

            The IP-address is the same as you mentioned.

            Nikon Wireless Utility also doesn´t work really, but worked also with Android 4.4.4

            Connection via USB works pretty well.

          2. Try uninstalling the Nikon WMU application. I have a Nexus 7 2012 with Android 5 and works just fine with the D7100 + WU-1a. Also check the new V0.2.4

        2. Hi, have you been able to have your app work with your nexus 5? I have the D5200 and purchased the adapter and having similar issues.

  41. I have not been able to get qDslrDashboard to work, either through USB or through DDServer with a TP-Link MR3040. With the TP-Link router I have it flashed with the latest firmware. My Kindle Fire HDX can connect to the router Dslrcontroller SSID. But in qDslrDashboard it never connects to the camera. I see no camera listing in the connection screen. I am using a D810.

    So I installed qDslrDashboard on Windows 8 and I connected my D810 camera via the USB on the Surface Pro tablet. I still do not get any camera listing in qDslrDashboard when I tap on the USB connection button.

    What am I doing wrong?

      1. Thank you for the prompt reply.

        I flashed my MR3040 with the OpenWrt firmware from http://wiki.openwrt.org/toh/tp-link/tl-mr3040. The firmware file was “openwrt-ar71xx-generic-tl-mr3040-v2-squashfs-factory.bin”. I will look at the firmware files on your site. I believe the SSID was DslrController. I may be mistaken. I am talking about the wireless network name that shows up when you set your tablet to the MR3040 router.

        I will look again into the WinUSB driver again. I tried to install it before I posted but I don’t think I did it right. My end goal is not to use the WinUSB wired connection. I was testing the wired connection to try and isolate whether my issue was the router or not. If qDslrDashboard works when the camera is directly wired to the USB port on the tablet then the issue would probably be the router configuration.

          1. Thanks for the help on this. I downloaded the upgrade firmware and installed it. At first it didn’t appear to work at all. I still couldn’t figure out what was going on. I would press the network button is qDslrDashboard, it would search for DDServer, but then nothing.

            I finally found a sentence in the documentation to do a LONG press on the network button. That was the trick. It works now on both my Surface Pro and Kindle tablet. But you do have to do the long press.

  42. Hi Zoltan,

    Have a question for you please…

    I am using V0.2.3, Nikon D750 (RAW + basic JPEG), iPhone 6

    I have been trying time lapse with 5-second interval and 1-second shutter. That means there are about 4-second “quiet” time between shots. When I use D750’s internal timer, the camera takes a picture every 5 seconds precisely and never miss a shot. But when I use qDslrDashboard, the time gaps between shots are quite random such as 5, 6, 8, 10, 14 seconds for example. I suppose that is due to the transfer of the JPEG file over Wi-Fi??? And I have observed the same with both qDslrDashboard’s LRTimelapse and Interval Timer. So I am just wondering if qDslrTimelapse has a mode where it would just trigger the camera every 5 seconds and not trying to retrieve JPEG file from the camera so that to avoid the random time gaps?

    Thank you very much!

    Kind regards,
    Philip C

  43. Hi Zoltan,
    I´m using Nikon D5300 via built in wifi. I have problems with video recording, when I press the record button it focuses, turns the mirror up and swich of the wifi in DSLR. I have tested it with samsung galaxy s3 mini and Windows 7. Both made same. Can you help with this?

    1. I had the same issue when had the D5300 for testing and I think it is a firmware problem as the same with USB is working.

  44. Zoltan,

    It took me a little while to install and get the updates to work. I figured out the the new features and function and everything is working again!

    Thanks for this great application and the time/work you invest.


  45. Congratulations, what an amazing bit of software and considering what Nikon are charging for this, I wish to express my appreciation to you guys.
    One single problem only for my Nikon D800 and this program is it will not fire my flash and I need my flash often for this type of remote shooting. Any chance of an update on this glitch, or am I not understanding the settings.
    Thank You

  46. Oops sorry people I forgot to add the problem with the D800 flash is for the version number 0 -30-33 on my samsung galaxy S4.
    Thank you

  47. If using the TP-Link router with iOS ipad/iphone, do you need to upload the OpenWrt firmware update to the TP-Link router?

  48. Zoltan,
    thank you for solution of my problem, but I have another one. I have my Asus EEE PC with Windows XP SP 3. I have problem to run your aplication according to you guide I install vcredist_x86, but when I try to run it, it shows that the aplication can´t be runed, because of missing VCOMP100.DLL (I don´t know if my translation is precise). Maybye it is some stupid mistake. I will apperciate if you could help me.
    Greetings from Czech Republic
    Jan Hubáček

  49. Hi,
    I would like to try dslrdashboard/server. I already have a MR3040 programmed w/LibraryBox-OpenWRT. I have been looking but can not find just the binary “ddserver” file. I did find the “ddserver*.ipk” file. But the windows-installer file is missing (the URL is broken). Are the necessary files and instructions somewhere to be found for installing dslrdashboardserver on an existing OpenWRT/MR3040 box?

    -thank you!

    1. Not sure what you mean under binary file. There is the .ipk file that is for OpenWrt and can be installed with opkg. Or you can use the Windows updater that will update the ddserver if you already have the ddserver OpenWrt firmware on MR3040. If you need the source it is here: https://github.com/hubaiz/DslrDashboardServer
      Installing the ddserver OpenWrt firmware on MR3040 is here: http://dslrdashboard.info/tp-link-mr3040-openwrt-flash/
      Updating the ddserver OpenWrt firmware on MR3040: http://dslrdashboard.info/tp-link-mr3040-firmware-upgrade/
      Updating the ddserver package (ipk): http://dslrdashboard.info/ddserver-package-updater/

  50. Hello Zoltan,

    i downloaded qdslrdashboard on my Samsung s4 mini (Android 4.2.2). After installing the app, i get the messsage “qdslrdashboard stopped”.
    Can you help me?

    Best regards


  51. Hello Zoltan,

    i have installed qDD on my smartphone samsung s4 mini (with Android 4.2.2), but qDD doesn’t run on it. I get always the message “qdslrdashboard stopped”. I have used the download für Android ARM and Android x86. Can you help me?

    Thanks a lot!

    With best regards

    Thomas Jung

      1. Hi Zoltan,

        thanks for you tip, now qDD runs on my smartphone. But i don’t get connection to my camera (Canon 7D). Need I another programm?


        1. Gunther told me this: ‘I use the Canon Utility to establish the connection first, otherwise you won’t be able to pair the devices.
          After the connection is established, you don’t need the app anymore, then you can just connect wifi and launch DDB.’
          Unfortunately I only have the 650D (it does not have the wireless function) so I can’t test this out.

  52. Hi,

    Im trying to connect the TP-Link TL-MR3040 to my new Pentax K-3. But as soon as i turn the TP on, the camera just shuts down and the only appearing message is pc-5 on the top-display. Besides that the camera seems dead until i plug the TP out.

    It worked great before with my old 450d, but now its not working anymore.

    Have you heard about similar problems from Pentax users or do you got any solutions to this problem?

  53. NIKON D700 with qDD on Mac Pc and iOs devices

    Here are the results of the tests I made …

    To shoot with qDD with an usb cable from PC or Mac you have to always disable liveview before shooting, otherwise the camera will not fire at all!

    In any case you have to set the focus mode selector on the camera to AF-C (i guess the camera this way is set to release priority, rather than focus priority).

    If you set the camera on S, the camera refocuses immediately after pressing the qDD shutter button on the remote device.
    So this way the camera lose the focus prior gotten in liveview.

    With the tp-link everything works good, with every kind of nikkor lenses AF-S, AF-D and old MF lenses (sometimes you have to reset everything anyway).

    If you comply with all the above directions everything works good for sometime

    in brief:

    A) AF mode selector on C

    B) START te qDD application as last with the tp-link running, with wifi ON and the camera connected and turned on.

    C) Reset all occasionally respecting the boot order.

    I do not know why but with the TP-LINK program works better than with USB cable

    I hope this will help for future app releases.

  54. Will this work with Nikon D3100 for live view? Camera does not have PTP or wireless. I have android phone I can connect via USB but the comments above look like without PTP in camera it won’t work please advise an alternative for D3100

    1. It will work with D3100 but no live view. The D3100 has only a basic set of PTP properties/commands so don’t expect miracles.

      1. So that means I cannot control/shoot video right? Just want to make sure before buying the app

  55. Well first of all, merry Christmas to you and your team!
    My question is, is it possible to use the program in combination with triggertrap? I would very much like to trigger the nikon D750 by movement detection, and on the documentation (camera control properties) I see button 2 (remote) but when I use the latest Mac app of qdslrdashboard, I do not see that button…
    Any chance of triggering the camera by movement detection?
    This would be super for Bird photography.
    And thank you so much for giving this marveleous program for free for pc and mac ( I did donate a bit tonight) 🙂


  56. Hi….Mr. Zoltan :
    I’m using 0.2.3 version and just bought a Sony a5100. When press Lrtimelapse icon in qdd, it displayed that my a5100 doesn’t support. Will your 0.2.4 support it? thanks.


    1. Not yet. Will try to add but currently I needed to return the NEX6 and can’t test now. Probably I will get a 5100 for testing sometime in February.

      1. Thanks for your effort. I will wait. Merry X’Mas and Happy New Year.

  57. Hi Zoltan,
    First of all, great work!
    I use Version 0.2.4 and a Nikon 5300 and would like to connect via WIFI.
    Some few times (every 30th try or around this) it connects, and I can work for some minutes. Than the connection drops after a short time and reconnects and so on.
    Mostly I got the error “Failed to connect to Nikon Wu-1a/1b/D5300”.
    The IP-Adress ist correct ( and also the Nikon WMU-tool can transfer data over WIFI without any problem.
    Any idea?
    Thanks a lot, Bernhard

    1. Please only use one application. If installed the Nikon WMU will establish connection to camera and stay in background and qDD will be not able to connect to it. So best you try and uninstall the Nikon WMU.

  58. Hello Zoltan Hubai,
    I just get the qdskrdashboard V0.2.4, after launching on my ipad/iphone, we have a connection screen buttons, but it does not include the USB button on it, and after connecting my d3300 and ipad air (iphone5), it says cannot connect to my device (not support it), but when i try it on nexus 7, it seems to work fine. I would like to know how to fix the problem.
    Thank for your help very much.

    1. On iOS devices USB connection is not supported only wireless. The Apple Camera Connection Kit API is not available for developers

  59. I added qDD V0.2.3 ARM on my tablet Sansung Galaxy Tab2 but it’s not running with OTG cable and Nikon D5300. What can I do? If I use wifi, it’s stops in LV mode when i starts shootting the video, so, I prefer use USB, but how do this? I will need another tablet?
    I am Brazilian and I desperately need help.
    Thank you so much.

  60. Hi Zoltan!
    Thanks for the great app, I’ve read a lot of good comments about it. Unfortunately I’m not successful with getting it to work myself.
    I’m trying to connect my 5DmkII+ml via TP-link to PC and GalaxyS3. I’ve got an OpenWRT installed and Ddserver 0.2-13, but the camera doesn’t want to get recognized. Galaxy S3 and Qdslrdashboard couldn’t recognize the camera wirelessly although Qdsldashboard+USB cable works fine. I’m connected wirelessly (S3/PC) so this is not the issue. I’ve tried AP, WISP and 3G modes on the router. I’ve lost my patience, no more ideas how to solve this.. Please help.
    Thank you!

    1. Connect your S3 wireless to TP-Link wireless (put the button in AP position)
      Connect the camera with USB cable to TP-Link and turn it on.
      Start qDD and press the ‘Network’ button, if it does not find the camera long press the ‘Network’ button and enter the IP addres (by default it is

      1. Thanks for your advice Zoltan, unfortunately neither way worked for me at the beginning.. Good news no1 – few seconds ago I’ve tried to change an IP address (to for TPlink, and it finally worked fine with qDD!
        Good news no2 – I’m sure no one will repeat the same mistake as I did, but .. actually I was trying to connect via different app, after noticing that the DSLR Controller started working just fine right away! 🙂
        Danke Schon!

  61. Dear Zoltan,

    Disregard my previous inquiry, I managed to solve the problem of installing in Win8. The program works lie magic. Thank you.

  62. Hey, cool app! Is it possible to record video with nikon d600 through tplink 3040 on an Ipad?

    The record video is grayed out! I tested on a canon t2i as well with no succes. The cameras are in live view and tried checking and unchecking the option in settings menu!

    1. Yes it is, you must change the live view mode to movie recording mode. You can do it with the camera properties display.

  63. Hi Zoltan!
    Is it possible to connect qdslr on mac os Yosemite directly to the d750 through its internal WU-1b wifi unit or do I have to purchase a separate wifi router? Ive tried it and I got this error message: “Failed to connect to Nikon WU-1a / 1b / D5300”.

    1. Yes you can. Enable the wireless control on D750, pair your MAC wireless with the D750 wireless, start qDD and press the ‘Nikon wireless’ button.
      If your MAC is also connected to your local network that uses the same address space as the D750 (probably then this will not work.
      If the D750 allow changing the address space (like then try it and then you can try and long press the ‘Nikon wireless’ button and enter the IP.

  64. I have an old and outdated iPad that I have put aside for 2 years. It is an iPad without camera, and the iOS is about 5. something. Does this app support such old iPad? I need it to do fine tunning the image when doing macro photography, and will be nice if I can just reuse the old equipment.

  65. Downloaded Version 0.2.7 for Windows x64.
    Ran the vcredist_x64.exe to install the Visual Studio C++ 2013.
    Launched the application with qDslrDashboard.exe
    Enabled wireless on my D5300.
    Long pressed the ‘Nikon Wireless’ button to verify that IP address is correct (
    Pressed the ‘Nikon Wireless’ button on qDslrDashboard.
    Get message “Trying to connect to Nikon wireless DSLR”, then, after a few seconds get message “Failed to connect to Nikon Wiresless DSLR”.
    Unable to get it to connect regardless of how many times I try.
    Please help!

    1. Did you pair your PC wireless with the camera wireless?
      Is your PC maybe connected to your home network? If yes what is your home router IP address? If it is then you will need to disconnect your PC from your home network.
      The ‘Nikon wireless’ button long press is not for checking the IP address but to connect to the entered IP address. The single press to ‘Nikon wireless’ will always try to connect to

  66. Thank you, Zoltan! I had not paired to my PC. Once I did that, it connected flawlessly. One question, though… When the “Play” button is pressed to playback images, how does one scroll forward or backwards through them? Pressing the arrow keys does not seem to help. Only the last image taken displays.

  67. Hello Dear,
    Can you please explain step by step use of focus stacking….as I can’t get it to work.
    (camera: nikon d750 – mobile: note 4)

    Thank you!

    Mazhar Nazir

  68. Hello Zoltan,
    I am using DSLR Dashboard for Android. I have a Samsung Galaxy Note 1 (N7000) and a Canon 5D Mk II.
    I want to use the exposure bracketing. I set the parameters (5 shots, 2EV between them), I enable bracketing and start shooting. The software makes 5 shots, but all of them have the same exposure. The camera is in Manual Mode, the lens I use is a manual focus one.
    How can I do 5 or 7 exposures with bracketing?
    Thank you so much!

      1. 100 ISO, 1/30s. f/11 but the camera shows 00 because the lens is Samyang.
        Thank you.

  69. It is suitable for Nikon D810 and LG Pro2 (android 5.0.1)?
    Beacuse no live view function.

  70. Hi, I have a Nikon D3100 and a Sony Z3.
    I downloaded the software from the Google playstore.

    I do not see the LV button on my screen.

    The reason I wanted this software is to have the LV.

    Please help.

    1. Even I downloaded the file from your downloads section. The phone says “Cannot Open File”

  71. Hi!
    I have the TP Link M3040, I installed the software on the router and on my iphone.
    I got it to connect once but ever since the only message I get is ” searching for DD server” and “failed to connect to Nikon DSLR”

    am I missing something?

    1. oh, I am trying to use it on a D4 and a D810.
      I installed qdslr Dashboard on my Iphone

  72. Hallo. um diese neue Version von dslrdashboard mit Nikon D90 verwenden, habe ich den Router OpenWRT-TL-MR3040-v1 aktualisieren?

  73. Will this work with D3200 ?
    I cannot find it in playstore when I search for dslr dashboard…. why ?

  74. Nikon D810 does not work with both USB or on wireless network. Qdslrdashboard closes without any error or message.

    I am using a Macbook Pro to connect the same.

    Through Ipad it works fine where I have purchased the app from App Store.

    Please help me connect the camera directly to the laptop through USB or wireless network.

  75. Hello,

    Is the DSLR Dashboard compatible with all Canon cameras (I have a 7D mark II, 100D and 1200 D) ?

    Thank you.

  76. Does not work with Nikon d7100 and Asus wi-fi tablet. So many posts that this app is not working with so many cameras, how can you ask for money ? Please, fix my problem or return my money. I tried many options , cables, settings NOTHING is working !!!

  77. i will the software support nikon coolpix p-530 using usb,or i need wi-fi adaptor

  78. Hi,
    trying to use your app with a Nikon D750 , iPhone6 and iPad Air and erverything works fine so far, exept one thing: I cant start videorecording via WiFi because the connection shuts down imedeatly. Everything else works fine. Can take pictures, cahnge settings, focus etc.
    The same if I connect to my iMac via Wifi. If I establish a USB connection to the iMac Videorecording works fine.


Comments are closed.